Printer Issues in Lion (Canon)

Discussion in 'Mac OS X Lion (10.7)' started by mixel, May 25, 2011.

  1. macrumors 65816

    mixel

    Joined:
    Jan 12, 2006
    Location:
    Leeds, UK
    #1
    I have a Canon iP4500 .. It runs perfectly in SL but under Lion it has some strange issues.

    It'll start printing a page, then stop and force you to press the sheet feed button and pause. It only seems to do it on some pictures/documents, while others come out fine.

    I know the driver isn't supposed to support Lion yet, I was just wondering if it’s a common Lion printer issue which there might be a work-around for?

    If not - I guess the thread is just a warning to Canon printer owners not to update until it's done.

    And before anyone asks, yes I am a registered developer. :)
     
  2. macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #2
    I hadn't tried printing with Lion until today.

    But with my Canon MX850 it seems to work just fine.
     
  3. thread starter macrumors 65816

    mixel

    Joined:
    Jan 12, 2006
    Location:
    Leeds, UK
    #3
    That's good to know, maybe its just a specific driver issue. Very frustrating not knowing what it's going to do with any particular file!

    Fingers crossed it's fixed by Lion launch.
     
  4. thread starter macrumors 65816

    mixel

    Joined:
    Jan 12, 2006
    Location:
    Leeds, UK
    #4
    Sorry to bump this, but it's still an issue here. Canon Pixma 4500 does not seem to work at all in Lion. sometimes it'll spit out a line or two but rarely a full picture, which is pretty bad for a photo printer. :O

    Ive tried rolling back drivers and all sorts but it doesn’t work whatever you try.

    If someone, somewhere can offer some glimmer of hope it'd be useful.. I'm not really in a position where I can downgrade at the moment!

    It always seems to be printers that give me problems.
     
  5. macrumors newbie

    Joined:
    Jul 13, 2011
    #5
    Printer issues in Lion (Canon)

    Has anybody tried a Canon S9000?
     
  6. macrumors newbie

    Joined:
    May 31, 2011
    Location:
    Munich
    #6
    I have a Canon ip4500, too and it runs fine with Lion GM installed.
    Have you checked software update? Yesterday, it showed me a driver update for canon printers. Maybe that helps!?
     
  7. macrumors newbie

    Joined:
    Jun 3, 2009
    #7
    Print issues in Lion

    I have a Canon MP980, and I have been very happy with it on SL. The quality of the photos have been excellent. But today, on my firts photo print with Lion, the photos look horrible. Very "synthetic" and light colors. I have checked Canon for the latest drivers, I use Canons own print program Easy Photoprint EX.
    I have also adjusted the printerheads and calibrated my 27" iMac screen.

    Anyone else any experience with MP980 on Lion?
     
  8. macrumors 65816

    Joined:
    May 7, 2009
    Location:
    Hamilton Island, Whitsundays, QLD Australia
    #8
    Canon LBP5050N was fine at first, yet now absolute **** under Lion.

    what a pity one can't go back to Snow Leopard on the new MB Airs.

    need to find a new colour laser printer that will actually feckin' work with Lion

    sheesh :rolleyes:
     
  9. macrumors G4

    Joined:
    Jul 17, 2002
    Location:
    USA
    #9
    The printer should work fine with the correct driver. For whatever reason, Canon will not release a production version of its Lion-compatible driver for your printer until October or November 2011. In the meantime, you may use the developmental driver.
     
  10. macrumors 65816

    Joined:
    May 7, 2009
    Location:
    Hamilton Island, Whitsundays, QLD Australia
    #10
    yes thanks for that.
    I already had downloaded that driver but found that it would only work after uninstalling every other canon driver and then reinstalling that one alone.

    next to try to get my MF4350d working also, though it shouldn't be that much of an issue being mono and not colour
     
  11. macrumors 65816

    Joined:
    Aug 14, 2009
    #11
    Did you get it to work? Mine refuses to print in Lion but worked fine in SL; I have driver 2.27.

    Any suggestions would be appreciated.

    Scanner works under VueScan so I know it is connecting at least.
     

Share This Page