1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Printer or Powerbook Problem?

Discussion in 'Macintosh Computers' started by Mem, Oct 8, 2004.

  1. Mem
    macrumors member

    Hi all,

    I'm hoping you can help me with this issue. I bought a Canon i860 printer recently (about a month ago) and it and the software it came with have been working like a dream...until yesterday. I went to print a document and it said there was a problem with the printer and it couldn't print. I checked all the cables, everything was hooked up fine. I tried printing things with other programs-still won't work. I opened Print Utility-the i860 was checked and everything looked in order. I was even able to clean the cartridges and the printerhead-which I thougth was strange becuase it printed those two things just fine. I had a Mac friend look at it and she couldn't find anything wrong with it either and thought it was a very strange situation becuase both the computer and the printer seem fine. Last night I decided to delete the printer from print utility and I was going to try to reinstall the driver. As I'm reinstalling it it finishes abrubtly by saying there was an error and the driver couldn't be installed. Now I'm stuck and have tried everything I can think of. Anybody know what's up?
  2. Mem
    macrumors member

    Anybody? Please
  3. macrumors 68020

    Rod Rod

    how about reinstalling the Canon printer drivers from your Mac OS X install discs?
  4. Mem
    macrumors member

    Thanks for the reply, Rod. I've tried reinstalling from the disks canon provided with the printer and have also tried to reinstall the driver from their website-but its the same problem-its ends as as error saying that the software couldn't be installed and to try again.

    Any other ideas?
  5. macrumors 6502


    call cannon.
    then call apple.

    or go to an apple genius
  6. macrumors 68000


    see if there are any new drivers available from the canon website? other than that im stuck for ideas! good luck!
  7. macrumors 68020

    Rod Rod

    maybe you need to delete all traces of your printer... delete the print utility preferences file, as well as whatever comes up when you do a finder search for "canon." (except the Photoshop files)

    after you delete all traces, then install the drivers again. that might work.

Share This Page