Printing Postscript (literally) - I want to Doc, not the PS code!

Discussion in 'Macintosh Computers' started by RedMacMan, Feb 11, 2004.

  1. RedMacMan macrumors member

    Joined:
    Sep 16, 2003
    Location:
    Chicago
    #1
    Ok this is probably a stupid question, but here goes:

    I've got my Powerbook G4 at this huge corporate client, and want to print to the Network HP LaserJet 4si printer on the other side of my cube. OS X.3 found the printer fine, but when I try to print anything, the printer spits out the actual Postscript code verbatim, instead of actually interpreting it and printing my file. What's going on? How do I fix it?
     
  2. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #2
    It sounds as if the printer doesn't have the PostScript option or it's not turned on.

    Try a more generic HP driver.
     
  3. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #3
    Re: Printing Postscript (literally) - I want to Doc, not the PS code!

    You don't want a generic driver; you want a GIMP-print+CUPS driver for the LJ 4si.
     
  4. RedMacMan thread starter macrumors member

    Joined:
    Sep 16, 2003
    Location:
    Chicago
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    Then use the GIMP-print + CUPS driver for the LaserJet 5si. I didn't mistype.
     
  6. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #6
    HP's printers use a native language called PCL. In order to parse PostScript, the printer driver is supposed to send a one-line PCL command that basically says "go into PS mode".

    Like others have said, try to use the specific driver and see if that fixes it. If it doesn't, look on HP's Website and find out how to reset the printer to its default settings.
     
  7. RedMacMan thread starter macrumors member

    Joined:
    Sep 16, 2003
    Location:
    Chicago
    #7
    Huh. That's interesting about the HP printers. Using the GIMP driver did the trick. Thanks for all the helpful replies.
     

Share This Page