Printing to a Ricoh Aficio MP 2550

Discussion in 'Mac Applications and Mac App Store' started by DMillerACS, Aug 13, 2012.

  1. DMillerACS, Aug 13, 2012
    Last edited: Aug 13, 2012

    macrumors newbie

    Joined:
    Aug 13, 2012
    #1
    Hello all,
    This is my first foray into threads like this.

    I work at a very small school and we have a Ricoh MP 2550. Unfortunately, in order to be able to print directly from my Mac to the Ricoh 2550, we apparently would need to buy a $650 postscript card. Since I am the only Mac user at the school, this will not happen. I am wondering if there are any applications or other ways out there for Mac computers that will solve this problem in a less expensive way.

    I know that there is an app for iPad and iPhone called Smart Device Print that allows one to print from it to a Ricoh printer on the same network without the $650 card. Does anyone know if there is an app similar to this in the Mac app store?

    Thanks for your help.

    I am currently running OS X Lion (10.7.4)
     
  2. macrumors 68020

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    It doesn't have postscript but it is a PCL printer.

    Add the printer as an IP (network) printer, and "Print Using:" the "Generic PCL Laser Printer" option.
     
  3. thread starter macrumors newbie

    Joined:
    Aug 13, 2012
    #3
    Thanks for the tip, but I am now having trouble downloading a driver for my computer that isn't a PPD. They have a PCL driver for Windows, but would that work if I downloaded it?
     
  4. macrumors 68020

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    I don't think you can use their drivers. The generic one built in on the Mac is as good as it's gonna get.
     
  5. macrumors newbie

    Joined:
    Aug 15, 2012
    #5
  6. thread starter macrumors newbie

    Joined:
    Aug 13, 2012
    #6
    I downloaded the driver from Gutenprint (this printer was supported), but now when I try to print something, the printer only pauses. When I resume printing, it just pauses again. According to the job message "The printer URI is incorrect or no longer exists."

    Does anyone know what I should try next?
     
  7. macrumors newbie

    Joined:
    Aug 16, 2012
    #7
    Hey DMillerACS,

    I have a Ricoh MP C2551 in my office and was also told I would need to purchase the postscript card. Like you, I am in the minority - only two of us use macs!

    I did find a solution that worked for me though.
    Check out - http://www.linuxfoundation.org/collaborate/workgroups/openprinting/macosxpxlmono

    Basically there are three steps. Install Foomatic. Install pxlmono. Install gplgs.

    Then when you add the printer it will work like it is supposed to. All features even. You should even be able to see supply level etc.

    I added the printer by using the IP address after installing everything as mentioned. The driver should come up automatically when you add it.

    Let me know if you have troubles and I will see what else I can add to help.

    Best of luck! and happy printing!
     
  8. thread starter macrumors newbie

    Joined:
    Aug 13, 2012
    #8
    ekko20six,
    Thanks so much for this tip. It worked for me too. Now I don't have to get my documents to another printer and print from there.

    To anyone else facing a similar situation, the previous post provided me with my solution.
     
  9. macrumors newbie

    Joined:
    Oct 5, 2012
    #9
    Strange problem

    First off: Thank you very much for the great fix offered. This has worked great on my MBP and my boss's.

    However, we are experiencing an issue on another mac in our building.

    The work around was great on our two 15" MBPs. However, we have a 13" MBP that this is NOT working on.

    We are all running the latest version of Mountain Lion (10.8.2).

    We are all connected to the same network, with the same signal quality.

    However, the 13" MBP is claiming that it cannot verify the printer. After pressing continue, it continually pauses the print jobs. It works through printer sharing, but nothing else.

    I have installed the Ricoh drivers, the Guten Print files, and even the pxlmono solution. Nothing seems to be working. Restarted the router, the computer, reset the printing system, everything that has been suggested.
     
  10. macrumors newbie

    Joined:
    Feb 21, 2013
    #10
    Hello,

    This fixed the issue with my Ricoh MP C2550, thank you.

    mykeg
     
  11. macrumors newbie

    Joined:
    Jun 15, 2013
    #11
    Thanks for the information... but i have a Ricoh Aficio SP C820DN which doesn't seem to be on the supported list...

    Can someone help?:)
     
  12. macrumors newbie

    Joined:
    Jan 21, 2014
    #12
    I installed the IP, but when I print, it does something crazy where it prints a bunch of letters and numbers. So......It is communicating wirelessly with it, but yet it is not getting the right signal
     
  13. macrumors newbie

    Joined:
    Aug 8, 2014
    #13
    same issue

    I'm having the same issue. Getting some coded pages and a bunch of empties?

    Anyone with a fix out there??
     

Share This Page