problem getting AC3 track to work

Discussion in 'Apple TV and Home Theater' started by vanfanel1, Dec 13, 2012.

  1. macrumors member

    Jun 23, 2009
    So I finally figured out how to remux my mpg (PS3 compatible) files into mp4 files using xmedia recode however I can't get the 5.1 sound to work. I think I did this correctly but is there something I'm doing wrong here. The video and the stereo AAC track work fine but I can't get the AC3 track to work on the appletv 3. Both tracks work fine on my pc.

    Attached Files:

  2. thread starter macrumors member

    Jun 23, 2009
    Ok, I gave up on xmedia recode and got mkvtomp4 to finish the job.
  3. macrumors member

    Dec 14, 2012
    It probably is the same issue discussed in this thread...

    If so, there is a workaround. You need to play the file, then hit select on the remote, change the audio track to stereo, then hit select again and change it back to surround. You should hear the surround sound then.

    XMedia Recode doesn't encode the audio tracks right. It apparently marks them both as default which the aTV os no longer tolerates. You would need subler or a similar program to uncheck the surround track as being a default track for the aTV to handle it like normal.

    I'm still trying to find a program like subler for windows, so unless you have a Mac, you may just have to deal with the workaround like I do.

    Alternately, you could use Handbrake to re-encode the entire file. Others have noted that it encodes multiple audio tracks correctly, but the tradeoff is that handbrake re-encodes the video stream even if it doesn't need it. Theoretically, if you set Handbrake's quality high enough, then the video recode won't be noticeable, but it still wastes a LOT of time waiting for it to re-encode the whole file.


Share This Page