Problem installing Boot Camp drivers

Discussion in 'Windows, Linux & Others on the Mac' started by MacVault, Jan 19, 2007.

  1. MacVault macrumors 65816

    Joined:
    Jun 10, 2002
    Location:
    Planet Earth
    #1
    After installing Boot Camp and Windows Server 2003 I tried installing the Boot Camp drivers from within Windows. I got the E:\Install Macintosh Drivers for Windows XP.exe to extract to C:\Macintosh Drivers for Windows XP.msi. But now when I try to run the msi I get the following error: This installation cannot be run by directly launching the msi package. You must run setup.exe. Any ideas?
     
  2. bearbo macrumors 68000

    bearbo

    Joined:
    Jul 20, 2006
    #2
    it's not the msi package you want to run, you need to find where you saved the actual drivers, and run them individually
     
  3. MacVault thread starter macrumors 65816

    Joined:
    Jun 10, 2002
    Location:
    Planet Earth
    #3
    It never asked me where to save them. I used E:\Macintosh Drivers for Windows XP.exe /A /v to extract it all, and I do remember it asking where to save an image or something for server deployment, or something like that - which must be the what the msi is. Do you know where it would have extracted the drivers to by default?
     
  4. bearbo macrumors 68000

    bearbo

    Joined:
    Jul 20, 2006
    #4
    when you did the /A /v, it will look like a normal installation process (at least the first part of it, since that really is just to extract the installers)

    but before it actually does the extraction (where it has the progress bar), it will ask you where to save it (i'm not sure the default place, but probably root of a certain partition, i assume). this is after the small window that usually says "gathering system information" or something like that
     

Share This Page