Problem of iTunes dropping AppleTV is getting WORSE

Discussion in 'Apple TV and Home Theater' started by jersey10, Sep 1, 2009.

  1. macrumors regular

    Joined:
    Jan 20, 2004
    #1
    I have had several other threads on the problem with iTunes regularly dropping my AppleTVs, thereby forcing me to close and restart iTunes. Based on the responses to the thread, many others are having this same problem and no one has been able to find a solution.

    Lately, the problem has gotten worse as iTunes has started dropping the AppleTVs even in the middle of watching a show being streamed (either wirelessly or via Ethernet). Previously, the problem never occurred mid-show.

    Has anyone else had the problem worsen in this manner? More importantly, has anyone been able to find a solution to this problem?
     
  2. macrumors member

    Joined:
    Feb 22, 2004
    Location:
    South Dakota
    #2
    Connection Dropping

    I've noticed this problem recently too. It's hard to track down because it so sporadic. A couple months ago, I switched from an HDMI connection to a component cable/rca cable to carry the audio/video. Don't know why an HDMI cable would cause drops like that, but after switching, I didn't get dropped nearly as often.

    This week, I've noticed the drops coming back. For right now, I'm blaming it on me upgrading my Mac Mini to Snow Leopard. I'm hoping the forthcoming iTunes 9 (hopefully on Sept 9?) will help stabilize things again.
     
  3. macrumors 6502a

    Joined:
    Nov 8, 2007
    #3
    I've been having similar issues, so I unsync'ed my AppleTV with iTunes, let it delete all the content, then resync'ed.

    It's been a week and no random drops so far...
     
  4. macrumors member

    Joined:
    Nov 19, 2008
    #4
    I know that my router (D-Link) was rubbish. I couldn't stream a film for more than five minutes and it would drop out of iTunes. I picked up a Base station extreme from the Apple store, since then, never had a problem. So my problem was definately my router. I had other issues in my network as well, that's why I decided to trash it.:p
    Cheers.
     
  5. macrumors 6502a

    Joined:
    Nov 19, 2006
    #5
    At one time I was plagued with this same issue - I struggled with firmware revisions for my Airport Extreme, restarts, reboots, fistfights with iTunes and solutions that seemed permanent but which in fact would only last a couple of days. I finally threw in the towel.

    What has resolved the whole issue for me is not a particularly Apple-centric solution but rather - XBMC and a patchstick.

    As much as I like the Frontrow interface, Mediastream is much better looking and since turning off the automatic updates - I haven't had one dropout.

    It goes against the grain a bit to use hacked software on something that should "just work" but honestly - the :apple:TV in its current form "just sucks". It's underdeveloped and underpowered period.
     
  6. macrumors G3

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #6
    Just curious. Are you working in a Mac only environment or a mixed environment? I have had my iTunes "server" on my windows xp box which I then have an apple tv and two macs connected to. I have yet to have the apple tv drop from iTunes.

    One thing that I do see it my apple tv will come on for no reason. But other then that I haven't had iTunes drop the apple tv.
     
  7. thread starter macrumors regular

    Joined:
    Jan 20, 2004
    #7
    My iTunes is on a Mac, connected to a 1TB external hard drive holding all my movies, TV shows, etc. I also have a Macbook and a PC laptop that connect with the same wireless network, but which don't have any connection to my iTunes.

    Everything worked flawlessly on both my AppleTVs for over a year, it is only in the past few months that this problem of iTunes dropping the AppleTVs arose. Others have suggested possible problems with the wireless network, but that can't be the issue as one of my AppleTVs is connected via Ethernet cable.
     
  8. macrumors G3

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #8
    So you loose both of your apple tv's? Do you loose the connection of both at the same time?
     
  9. thread starter macrumors regular

    Joined:
    Jan 20, 2004
    #9
    Yes. I lose both at the same time. I don't think iTunes has ever dropped just one of them - it is always both AppleTVs.
     
  10. macrumors 65816

    Aldaris

    Joined:
    Sep 7, 2004
    Location:
    Salt Lake
    #10
    Drop outs from G4

    I hope and pray the new wake on LAN with 10.6 fixes this, the problem is my MMD Dual G4 is completely useless whit Snow Leopard... Well I guess I won't know till I make the 100% Intel Jump.
     
  11. macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #11
    2 days since installing SL and I haven't lost connection to my 3 Apple TVs yet. We'll see how it goes.
     
  12. macrumors 65816

    randy98mtu

    Joined:
    Mar 4, 2009
    #12
    Is your host computer wired or wireless?

    I have my content on my iMac, wired to my ATT 2wire router. I've never had it drop on the wireless. I have another Linksys hub wired in the living room. I plug the ATV into it when I'm using it down there and I've been having some trouble there. But my cable from the wall to that hub comes out of the hub, so I can't say it's the ATV having trouble. I need to get a new cable for it to rule that out. If I continue to have trouble though, based on other comments here, I'd likely blame that on the Linksys.
     
  13. thread starter macrumors regular

    Joined:
    Jan 20, 2004
    #13
    My host computer is wired. And one of the AppleTVs is connected via Ethernet, the other wirelessly.
     
  14. macrumors 65816

    Aldaris

    Joined:
    Sep 7, 2004
    Location:
    Salt Lake
    #14
    As for me, My G4 is wired to an AirPort Extreme N, and my 2 Apple TV's run wireless.

    I'm hoping to upgrade to a Mac Pro and deck it out for serving up iTunes content. But I think this wake on LAN might be the catalyst that will end the painful connection drops.

    Does anyone else experience a problem when a video file is playing, and then Audio buzzes, and picture goes to still frame, even though the file is still playing (timeline/scrubber)?

    I have experienced this a few times, and was just wondering if there was a fix.

    It is not the same file, and seems somewhat random.
     

Share This Page