Problem Sharing Internet via Airport - Comp 2 Comp

Discussion in 'Mac Help/Tips' started by sandro, Jan 17, 2003.

  1. sandro macrumors member

    Joined:
    Nov 8, 2002
    Location:
    San Francisco
    #1
    Hi there friends, I have a broblem, I'm trying to share the internet between my PowerBook G4 and an iBook G3, when the G3 is the one connected to the internet, I can connect to the internet by connecting my G4 to the G3, no problem, but when I connect my G4 to the internet and then connect the G3 to the G4, I can't use the internet on the G3, it shows that it is connected to my G4 but NO INTERNET. I have all the settings the same on both, does anyone know what could be wrong? there are no firewalls in place in either computer and appletalk is on on both computers aswell, and I can create a network between the two without a problem. Any help will be appreciated
    Thanks
    -Sandro
     
  2. theranch macrumors 6502

    Joined:
    Jan 3, 2002
    Location:
    Atlantic City area
    #2
    Re: Problem Sharing Internet via Airport - Comp 2 Comp

    You used Airport in the subject line but didn't mention it in the message. Are you using an airport? Do you have a ethernet hub? Are you connecting to the internet via dialup or cable or dsl? Without knowing the settings it's hard to troubleshoot the problem.
     
  3. sandro thread starter macrumors member

    Joined:
    Nov 8, 2002
    Location:
    San Francisco
    #3
    Sorry about that!
    I'm using airport cards on both machines BUT no Airport base at all. Thanks
     
  4. theranch macrumors 6502

    Joined:
    Jan 3, 2002
    Location:
    Atlantic City area
    #4
    oh...

    Well what good is it to have airport cards and no airport? That's no fun. So you don't have a hub of any kind? How do you connect to the internet? I'm having trouble giving you help without info.
     
  5. sandro thread starter macrumors member

    Joined:
    Nov 8, 2002
    Location:
    San Francisco
    #5
    Re: oh...

    No I don't need an airport base, One of the two computers is connected to the internet via a modem and it broadcast the signal to the other one via Airport card, so at least one of them is truly mobile, and connected to the net, but when I switch the computers, the service doesn't exist.
     
  6. theranch macrumors 6502

    Joined:
    Jan 3, 2002
    Location:
    Atlantic City area
    #6
    Re: Re: oh...

    OK...ok...I didn't know that you could share the connection with two airport cards. Are you running OSX on both? It's pretty easy to share the connection in the "sharing" prefs inside the system prefs in OSX.
     
  7. MacBandit macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #7
    From what I know about hubless Airport what you are doing shouldn't be doable. Technically you need a hub to share an internet connection. I had a similar question a while back and was asking people if I could just set up a software hub without a basestation and share my internet connection with just an Airport card and the answer I received back was an emphatic no.

    So if you have success going the other way around let me know. This sound very intersting. I guess those in the know don't really know.
     
  8. Rower_CPU Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #8
    Just to clarify something, you've been able to use Software Base Station (SBS) in 9 and Jaguar, but not in 10.0/10.1.

    The process (in 10.2) is:
    1) Open the Sharing prefpane
    2) Click the "Internet" tab
    3) Click the "Start" button
    4) Specify settings (if neccessary)

    Soooo, if you're running Jaguar or 9 on both machines it should be straightforward. Would you mind posting a screenshot of your prefs or control panel?
     
  9. MacBandit macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #9
    I know about software base station but I was told that it could not share an internet connection it just allowed you to connect two computers using airport cards rather then having to go through a base station.
     
  10. Rower_CPU Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #10
    Nope, it's for sharing the internet connection...hence it being located in Sharing>Internet. ;)

    You need to be connected via ethernet or modem for you to share your connection over airport.
     
  11. sandro thread starter macrumors member

    Joined:
    Nov 8, 2002
    Location:
    San Francisco
    #11
    my friend, this sure is possible, even MacAddict magazine wrote a whole article as to how to share the internet without a base station and Apple also has articles online about it, the only trick is that there is a sequence when clicking on "Start" sharing and creating a network. I'm running Jaguar 10.2.3 maybe it wasn't possible before
     
  12. sandro thread starter macrumors member

    Joined:
    Nov 8, 2002
    Location:
    San Francisco
    #12
    as a matter of fact, I'm writing this reply with my G4 connected to the net wirelessly thru an iBook which is connected to the net via a modem (NO basestation)
     
  13. zimv20 macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    toronto
    #13
    it will work

    as others have said, this is entirely doable. i did it last week.

    my setup:

    - Linksys router (non-wireless) hooked up to dsl.

    - g4, w/ airport card, hooked up to router

    - ibook, w/ airport card, sitting in living room

    both machines are running 10.2.3.

    you have the option of setting up a peer-to-peer network or a dhcp server on your "base station." i recommend the latter.

    on the "base station" (i.e. my g4):

    1. in network control panel, use the pulldown to show "Airport." in the tcp/ip panel, set it to configure manually and hardcode an ip address. i use: 10.0.1.1 and 255.255.255.0 for the subnet mask.

    2. click on the Airport tab and ensure that "Allow this computer to create networks" is checked.

    3. go to Sharing control panel, Internet tab. make sure you've enabled "Share your internet connection w/ other Airport-equipped computers"

    4. click the Airport options... button. enter a network name. i enable encryption and use a 128-bit scheme. you'll have to give your network a password (highly recommended).

    5. in the Sharing/Internet control panel, click Start

    6. if you don't see the airport icon in the menu bar (upper right), turn that on in Internet Connect (in the Applications folder)

    7. in the airport icon, you should see some grey concentric arcs (meaning airport is turned on) and a solid arrow pointing up (meaning DHCP airport is active)

    on the airport client (my ibook):

    1. in network control panels, go to Show: Airport and configure using DHCP. btw i have the earthlink DNS addresses typed in there but i don't think it's necessary.

    2. make sure the airport icon is in the menu bar. it should be the grey concentric arcs (if not, open Internet Connect and turn airport on).

    3. click on the menu bar airport icon and select the airport network name you made in step 4., above

    4. in the popup, enter the password you made. i store mine in my keychain (there's a checkbox for that) so this step can be skipped later.

    5. the grey concentric arcs should now be black. if so, you've got internet access!

    6. every time i wake from sleep, i must repeat step #3.

    EDIT: i found a workaround. in Network/Airport, there's an option on what to do after restart or waking from sleep. i put it on "join most recently used available network," turned on remember network password, and now it automatically reconnects.

    that's it! and because you're running DHCP, anyone can come over w/ their airport-enabled laptop and get your network (assuming you give them the password, which is why you want to make one)

    one further note:

    before i set up the dhcp model, i did peer to peer. as part of that effort, i had to make a change to hostconfig. i don't know if that's necessary for dhcp. so if the above doesn't work, do this step on your "base station."

    i hope you know how to use the terminal, command line, and vi.

    1. open a terminal
    2. su to root
    3. cd to /etc
    4. edit hostconfig (i use vi)
    5. ensure that IPFORWARDING is turned on. it should look like:

    IPFORWARDING=-YES-

    6. save the file
    7. you may have to restart
    8. try the "base station" airport stuff again

    NOTE:

    sometimes, on the "base station," my network doesn't want to turn on when i press Start in Internet sharing. to remedy, i open Internet Connect, turn airport off, turn it back on, then try Start again. that works for me.

    despite the length of these instructions, it's actually quite straightforward.

    good luck!
     
  14. MacBandit macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #14
    This is certanly a great thing. It will save me a lot of money when I finally go wireless since I only need to supply a range of about 20 feet.

    [edit] I just remembered what might have made the difference when I originally posed the question about sharring internet from a software base station.

    I want to be able to share it with another device that uses an 802.11b dongle rather then an Apple with an Airport card.

    Will this work?
    [/edit]
     
  15. sandro thread starter macrumors member

    Joined:
    Nov 8, 2002
    Location:
    San Francisco
    #15
    So looks like the macRumors forum had a bad crash and the whole thing got reverted to yesterdays posts and of course the solution that i posted earlier GOT ERASED, I'll try to write it again when I get some time, it was kind of long, so if "paulwhannel" reads this, could you repost your last posting? Thanks
     

Share This Page