Problem with Compilation and showing Artist in the browser

Discussion in 'iPod' started by oyalhi, Oct 18, 2009.

  1. macrumors member


    Oct 18, 2009
    Interesting problem, I have about 10 CDs which are all compilations and they are all checked as so. At the top, where the browser shows Genres, Artists, Albums, some of the compilations will show the Album Artist name under Artists and some of them not. All the albums have Album Artist part filled out.

    Deleting them from library and re-adding them did not help. Reentering the Album Artist name (first delete then re-add) did not help either.

    What makes iTunes show the Album Artist name under the Artists (in top browser) for the compilations?

    Your help is appriciated.

    I have Mac OS X 10.5.8 and iTunes 9.0.1
  2. macrumors 65816


    Mar 11, 2009
    Edinburgh, UK
    I think you have to deselect the compilation option.

    For some reason iTunes hides artists if they're in a compilation. That's what solved the same problem for me anyway.
  3. thread starter macrumors member


    Oct 18, 2009
    Deseleting the compilation puts the "Artist" name as you point it out. I don't want that. I would like to select it as a compilation and hide out the artist name (because in a compilation cd you may have many many artists), instead I want to show the "Album Artist".

    For example I have DJ Tiesto In Search of Sunrise vol 6 (for example), I do not want to see the Artists for each song, instead I want to see the DJ Tiesto as the Album Artist - showing under the "Artist" when the CD is a compilation.

    Some of the compilations CDs do this some of them don't. And I could not figure out how to enable this.

  4. macrumors regular

    Aug 30, 2009
    Unfortunately, iTunes' browser shows Artists and not Album Artists. At this time, there's no way to change this behavior.
  5. macrumors Westmere


    May 16, 2008
    The Browser at the top never shows Album Artist. It only shows Artist.
  6. thread starter macrumors member


    Oct 18, 2009
    Actually you are right. I thought I checked compilation for all the items and it seems that I did not and that's what was confusing me.

Share This Page