Problem with External HD - advice needed

Discussion in 'Macintosh Computers' started by margotspop, Jun 14, 2004.

  1. margotspop macrumors regular

    Joined:
    Jan 12, 2004
    #1
    Bought a 160 gig 8mb WD hard drive about 3 months ago, mostly for my music. Over the last few weeks it's had a habit of freezing up iTunes and the only thing I could do was pull the plug on my iMac. However, I could live with that.

    This last week though, every track I listen to is plagued with these pauses, whereby the track just stops from anything from a second to five seconds or more. I'm assuming there's some delay in reading from the HD. I don't think the problem is with iTunes since I can play a track from my internal HD and everything is fine. This happens even when the only app I have going is iTunes and nothing else is reading/writing to that Hard Drive. It's driving me nuts. I ran Disk Warrior on it, but no improvement.

    So last night I decided to put my library back on to my main HD - which meant freeing some space up - so I copied over an iMovie project to my external HD (about 22 gigs in size). I started the copy at about 10pm - by seven this morning it was still copying (had about 4 gigs left to do). This can't be right, surely? Firewire has to be faster than that!

    Is my HD screwed? Is there anything I can do before I send it back and try to get refund? Any advice much appreciated. Thanks
     
  2. Crikey macrumors 6502

    Joined:
    Jan 14, 2004
    Location:
    Spencer's Butte, Oregon
    #2
    It does seem like you're not getting the performance I'd expect from your FireWire drive.

    Is the drive located somewhere where it is getting hot or not getting ventilated?

    Also, have you tried using a different FireWire cable? Cabling problems can be subtle yet have profound effects.

    I haven't yet had to investigate MacOS X's tools for drive diagnostics and repair, so another MacRumors poster will have to make recommendations about that.


    Crikey
     
  3. margotspop thread starter macrumors regular

    Joined:
    Jan 12, 2004
    #3
    Thanks for the reply, Crikey. I'll see if I have another cable to swap it out with.
     
  4. legion macrumors 6502a

    Joined:
    Jul 31, 2003
    #4
    I copy 20GB over a 100BT network to a USB2 drive in about 18minutes. You should definitely be able to do better than what's happening. Internal to external drive would be a few minutes max.
     

Share This Page