Problem with .Mac and Mail (can't send email)

Discussion in 'Mac Apps and Mac App Store' started by ravenvii, Feb 19, 2005.

  1. ravenvii macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #1
    I'm having problems with .Mac and Mail. I can receive mail fine, but I can't seem to send them. The problem seemed to start today, though I haven't used my @mac.com address to send recently. When I tried to send something from my @mac.com address, I got a dialog saying Mail can't send my email, and there's a drop down menu with other servers. I'm using the default smtp.mac.com: (username), but there's also another smtp.mac.com, this one without the : (username). I tried to use that one, and it worked. I tried to go into preferences and change the outgoing server to the second one, and what do I know, they added : (username) to it, and now I have two smtp.mac.com: (username). Now for testing, I created a new server, again named smtp.mac.com, and didn't choose it as the outgoing server for my .Mac account. Tried to send another email, sure enough it couldn't send. Then I choose the newly created smtp.mac.com server, and IT WORKED.

    Now... what the hell is going on? Why would Mail add : (username) by default if that doesn't work?!
     
  2. mslifkin macrumors regular

    mslifkin

    Joined:
    May 14, 2004
    Location:
    New Jersey
    #2
    Hi,

    It's probably your ISP blocking the outgoing mail. The same thing happened to me ... worked fine for awhile, then stopped for no apparent reason. The solution is to use your ISP's SMTP address as your outgoing mail server. Just click on the Outgoing Server dropdown box, and select Add Server. That should do it.

    Regards,
    Marc
     
  3. ravenvii thread starter macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #3
    I also have two another email addresses, and their outgoing servers work fine. So it can't be the ISP.
     
  4. liketom macrumors 601

    liketom

    Joined:
    Apr 8, 2004
    Location:
    Lincoln,UK
    #4
    i get that also , i have NTL/.Mac e-mail setup and when sending with NTL i will have to switch smtp servers for it to send the e-mail.

    i think there is a way to default the smtp to e-mail account but i'm too lazy to work it out so i just select the correct smtp server when it pops up
     
  5. McApple macrumors newbie

    Joined:
    Feb 20, 2005
    #5
    I had a problem like this, so I went to Apple's support site to see what I should do and I found this.

    It says to change the default server port from 25 to 587.

    Hope this helps. :)
     
  6. ravenvii thread starter macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #6
    And... it worked! Thanks man!
     

Share This Page