Problem with Maill.app

Discussion in 'General Mac Discussion' started by chmorley, Feb 22, 2002.

  1. chmorley macrumors 6502a

    chmorley

    Joined:
    Jan 2, 2002
    Location:
    Denver, CO
    #1
    I had been having this problem sporadically, but it has become a consistent thing since 10.1.3. This may be coincidental--I don't know.

    My DSL connection (dynamic) is shared over my wireless network. Whenever the connection has not been used for a bit and Mail.app is the first thing that uses it, it first takes forever to fail to connect, then messes up all of my other internet apps. I actually have to restart! I have tried force quitting Mail, but then my browser still cannot make a connection until I restart. The only thing I've found that resolves this is quitting Mail when I put my computer to sleep, then using the browser before getting my mail. This works, but it's a pain in the ass--and it's not the way things were working.

    I am not at all sure, but I am thinking it has something to do with the dynamically assigned IP address. I am thinking maybe Mail.app makes an *odd* request to the server. Truth is, though, I don't have the slightest.

    Anyone else having this? Anyone have any guesses at solutions? Is there a way to stop Mail from looking for mail once it has started (some *stop* command)?

    Thanks in Advance,
    Chris
    :confused:
     
  2. whfsdude macrumors 6502a

    Joined:
    Jan 20, 2002
    Location:
    Washington DC USA
  3. chmorley thread starter macrumors 6502a

    chmorley

    Joined:
    Jan 2, 2002
    Location:
    Denver, CO
    #3
    ISP

    A local Denver company called 4dvision. They are pretty mediocre and not at all Mac-friendly. I use them because they are cheap, and I figured I was PC-savvy enough to make it work. This has been true for almost 2 years. Now I'm not so sure...

    Chris
     
  4. Taft macrumors 65816

    Taft

    Joined:
    Jan 31, 2002
    Location:
    Chicago
    #4
    Fire?

    Are you by any chance running Fire? I had problems similar to this whenever I had Fire running. What are the other internet applications you have running? I don't think I'd automatically blame Mail, even though it seems like this is whats causing the problem.

    If you can't find another source of the problem, try trashing some preference files. Go to your user Library folder. There are some preference type files here and most reside one level deeper in Preferences. I have had luck with trashing preferences to fix some application related problems. You may also be able to trash some system level preferences for network configuration.

    As was the case in OS 9, trashing prefs really doesn't hurt anything. The worst that will happen is that you'll lose settings in applications and the system.

    Hope this is of use.

    Matthew
     
  5. chmorley thread starter macrumors 6502a

    chmorley

    Joined:
    Jan 2, 2002
    Location:
    Denver, CO
    #5
    Fire

    Thanks for the suggestions, Matthew. I am not running Fire. I am using Brickhouse and have not yet tried turning it off. I will try that. If that doesn't work, I will trash my prefs.

    The only other internet app I have running all the time is Son of Weather Grok (SWG). It automatically checks the weather every 10 minutes or so. It is possible it makes a simultaneous request when the computer wakes up. I'm not sure why that would be a problem, but I will try turning it off, too.

    I appreciate any help. I am not used to having to restart OS X, and have become quite spoiled. I have even considered switching to Entourage.

    Again, this never happened before 10.1.3. The worst that would happen is that I would have to force quit Mail, and then everything else would work fine. Any chance this is either related to the most recent update to Mail (in 10.1.3) or changes in the OS?

    I will try those other suggestions when I get home. Thanks again.

    Chris
     
  6. chmorley thread starter macrumors 6502a

    chmorley

    Joined:
    Jan 2, 2002
    Location:
    Denver, CO
    #6
    help?

    This has been sitting here a few days without a new reply. Anyone have any ideas?

    Chris
     
  7. Taft macrumors 65816

    Taft

    Joined:
    Jan 31, 2002
    Location:
    Chicago
    #7
    DSL sharing?

    What are you using to share your DSL connection? A router? Software solution?

    Matthew
     
  8. chmorley thread starter macrumors 6502a

    chmorley

    Joined:
    Jan 2, 2002
    Location:
    Denver, CO
    #8
    My DSL router is connected to a small ethernet hub. That, in turn, is connected to an airport base station.

    CJM
     
  9. oldMac macrumors 6502a

    Joined:
    Oct 25, 2001
    #9
    theory...

    If your DSL provider is not doing IP leases on their DHCP server, then it's possible that your Mac is having to retrieve a new IP address every time it wakes up from sleep.

    Many DHCP servers are not very Mac friendly and a difference in the interpretation of the DHCP spec can cause some rather long timeouts during lease renegotiation.

    If this only happens when you wake from sleep, I suspect that might be it.
     
  10. chmorley thread starter macrumors 6502a

    chmorley

    Joined:
    Jan 2, 2002
    Location:
    Denver, CO
    #10
    ISP

    Thanks for taking the time to respond, OldMac. This makes sense, and is along the lines I was thinking. Any ideas on why it might have just started since 10.1.3? Could just be coincidence, but does anyone know of any changes in 10.1.3 that might be related?

    Chris
     
  11. Rower_CPU Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #11
    Did any of your prefs for Network get changed when you updated?
    Usually the updater doesn't touch that stuff, but you never know.
    For instance DHCP settings for your Airport.
    When my TiBook wakes up from sleep it takes a few seconds to log back on to my Airport network. It thinks it's offline if I try to check mail too quickly.
    Other than that, just turn off "Check mail every ___ minutes" in Preferences to prevent it from checking automatically.
     

Share This Page