Problem with off/on button?

Discussion in 'iPhone' started by gadgetmonster, Nov 14, 2012.

  1. macrumors regular

    Joined:
    Feb 3, 2011
    #1
    Anyone had an issue with their top right hand side button either not turning the screen off or on, or a delayed action? Mine has been doing this. It is quite annoying.
     
  2. thread starter macrumors regular

    Joined:
    Feb 3, 2011
  3. macrumors newbie

    Joined:
    Jul 12, 2010
    #3
    I actually was just going to post the same thing. I just started experiencing this the last 2 days. Throughout the day I would have to push the on/off button several times for it to go to sleep. Is anyone else experiencing this problem?
     
  4. macrumors regular

    Joined:
    Dec 4, 2006
    #4
    Same thing has been happening to me. I posted about it a few days ago but no one really supported me. Any thoughts about what you all want to do? Exchange? Will Apple do that for this?
     
  5. macrumors newbie

    Joined:
    Jul 12, 2010
    #5
    I saw some other threads where people had the same problem. It looks like if you press on the left side of the button it works fine. If you press on the middle or more to the right that is where it has issues.

    Sounds like others have gone to the Apple store and they replaced it with a new one.
     
  6. macrumors 6502a

    Aaleck

    Joined:
    Oct 11, 2007
    Location:
    Michigan, USA
    #6
    Mine stopped working like yours. I would have to push it a few times to turn it off/on, sometimes it would recognize all of the pushes and the screen of flash on and off. Called apple and they shipped me a refurb replacement
     
  7. thread starter macrumors regular

    Joined:
    Feb 3, 2011
    #7
    same thing happens to me; looks like i'll need to bring it to a store for a replacement.
     
  8. macrumors newbie

    Joined:
    Jun 17, 2012
    #8
    Same thing here. Sometimes it works okay tho, so I hesitated to go to the Apple Shop, since it's quite unpredictable whether I can show them the problem.
     
  9. macrumors member

    Joined:
    Aug 20, 2010
    #9
    same happened to mine.

    Got it exchanged a couple of days ago at the apple store. It becomes annoying, and after a while even the pressing the left side stopped working for me.

    might as well get it exchanged.
     
  10. tvith, Nov 15, 2012
    Last edited: Nov 16, 2012

    macrumors member

    Joined:
    Nov 1, 2012
  11. macrumors 65816

    Joined:
    Jul 27, 2012
    Location:
    Hollywood, CA
    #11
    Damn, can't help but notice the amount of problems people are having with the 5.

    I know, I know, every iPhone generation has issues.

    But I feel like people on here have complained about EVERY component on the iPhone 5, collectively.

    I mean how hard is it to just make a physical button that works.
     
  12. macrumors regular

    Joined:
    Dec 4, 2006
    #12
    Going in a few hours. Set up the appt in store so they saw the defect and admitted it wasn't normal. I'll let you all know how it goes.
     
  13. macrumors regular

    Joined:
    Dec 4, 2006
    #13
    Walked in. Showed them the problem. Walked out 15 minutes with a new perfect phone. Easy as that.
     
  14. thread starter macrumors regular

    Joined:
    Feb 3, 2011
    #14
    They replaced mine with a new one today as well, no big deal and it only took 15min.
     
  15. tgi
    macrumors 65816

    tgi

    Joined:
    Aug 29, 2012
    #15
    How long of a delay are we talking about? Has it done it right of the box?
     
  16. macrumors 6502a

    Matthew9559

    Joined:
    Apr 7, 2007
    Location:
    Texas
    #16
    I had the same thing with my iPhone 4 last year. They handed me a new one after a few seconds of showing the guy the issue.
     
  17. macrumors regular

    SarZ

    Joined:
    Mar 11, 2008
    #17
    I had the same problem with my iPhone 5 and it was replaced by Apple.
    Here is the thread where I mention the problem http://forums.macrumors.com/showthread.php?t=1484788

    Out of curiosity do any of you use a magnetic case on your iPhone?
    My problem started a few days after I started to use a magnetic case
     
  18. macrumors member

    Joined:
    Jun 3, 2012
    #18
    I went into a Apple store on tuesday and the Apple jerk basically blamed me :mad: saying that I was looking to much into it and that it looks perfectly normal to him, so he did a "DFU Wipe" and said it should be better... a couple days later and it's worse!:mad: Made an appointment to go back today... hopefully it gets fixed this time.
     
  19. macrumors 6502a

    Ih8reno

    Joined:
    Aug 10, 2012
    #19
    Mine wouldn't work when clicking in the right side. I brought it to an apple store and the employee said its a hardware defect and switched it out for me in 5 min.
     

Share This Page