Problem with Safari & Textedit since 10.3.2 installed

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Mike Davies, Feb 18, 2004.

  1. Mike Davies macrumors newbie

    Joined:
    Feb 18, 2004
    #1
    I have G4 Powerbook running OS9 & OSX. I have set OSX to have 2 different user id's (both administrators). Until recently I was running 10.3. I upgraded to 10.3.2 and since then I am problems with Safari & Textedit (they do not respond - I have to force quit) This only happens under one identity, but is OK under the other i.d. why is this? I am up to date with downloads etc. I am confused.
     
  2. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #2
    Have you tried repairing permissions? If not, go to Disk Utility in your Utilities folder (inside Applications), select your disk and click Repair Permissions. Failing that, try deleting these applications' preferences (go to your home folder, then Library, Preferences). For Safari, there is com.apple.Safari.plist, and for TextEdit there is com.apple.TextEdit.plist. For Safari, also try deleting (or temporarily moving) your Safari folder from Library.
     
  3. Mike Davies thread starter macrumors newbie

    Joined:
    Feb 18, 2004
    #3
    Thanks. Repairing permissions did the trick. I had done so after upgrading but did not realise I had to do so with all accounts. (doh, old OS9 user OSX newbie)
    Thanks again, my first day on the forum and a result. :)
     
  4. Billicus macrumors 6502a

    Billicus

    Joined:
    Apr 3, 2002
    Location:
    Charles City, Iowa
    #4
    You don't necessarily do the repairs from every account, but you do have to perform the repairs from an Administrator's account. :)
     
  5. Mike Davies thread starter macrumors newbie

    Joined:
    Feb 18, 2004
    #5
    Back to square one. The fault has re-ocurred. Permissions have been repaired in main account. But on second account Textedit & Safari do not respond, also Disk Utility does not now respond and software update does not work in the second account. What to do, secondary account seems to falling apart. Do I delete second account and start afresh. (if so how to keep email settings etc. in second account)?
     
  6. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #6
    It may be a good idea if you can't find the cause of the problem. Keep the account for a while, just to make sure you don't lose any data. When you create a new one, copy all the files that aren't in the Library folder, as these won't be causing the problem, then go through the Library folder of the corrupted one, and copy any files that look useful eg the Mail folder has all your email (assuming you are using Apple Mail). Beware though, that one or some of the files in Library may be the cause of the problems.
     
  7. Mike Davies thread starter macrumors newbie

    Joined:
    Feb 18, 2004
    #7
    Thanks for that idea, I will try it. I need all the help I can with OSX, I don't know where everything is. I've been OS7-OS9 for 10 years and could solve most probs, but I'm a relative virgin in X.

    Mike
     
  8. Billicus macrumors 6502a

    Billicus

    Joined:
    Apr 3, 2002
    Location:
    Charles City, Iowa
    #8
    Do a search and delete items like Safari.plist & Textedit.plist . That will delete the general preferences for those applications and may help you fix them.
     

Share This Page