Problem with telnet / terminal

Discussion in 'Mac Apps and Mac App Store' started by davrouk, May 31, 2004.

  1. davrouk Guest

    #1
    Wierdest thing has started to happen when I telnet to my TiVo

    The character I type is displayed twice in the terminal, but only relayed to the TiVo once.

    ie, i type pwd and ppwwdd appears on the display, but the TiVo responds to the command correctly.

    Does anyone know how I can fix this? I am on MacOS X 10.3.4 if that makes any difference, and it has worked fine previously! I assume I need to change the telnet settings, but I have no idea how to do this!

    Here is a copy direct from the terminal window:

    Paul-Davies-Computer:~ pauldavies$ telnet 192.168.1.10
    Trying 192.168.1.10...
    Connected to 192.168.1.10.
    Escape character is '^]'.
    bash-2.02# llss^M
    bash: ls: command not found
    bash-2.02# ppwwdd^M
    /var/tmp
    bash-2.02#
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Local echo is turned on. You have to turn it off.
     
  3. davrouk thread starter Guest

    #3
    Do you happen to know how i do this? Total novice with command line settings!
     
  4. jmbevan macrumors newbie

    Joined:
    Nov 2, 2008
    Location:
    Marlborough
    #4
    How to turn off echo for Tivo in Telnet for Mac OS X

    instead of telnet xxx.xxx.xxx.xxx use telnet -K xxx.xxx.xxx.xxx - the -K stops auto login to the remote system - I think the setup goes wrong if it tries to do it.
     

Share This Page