Problem with Terminal/router/hostname

Discussion in 'General Mac Discussion' started by nitz, Jan 14, 2004.

  1. nitz macrumors member

    nitz

    Joined:
    Jan 23, 2003
    Location:
    Germany
    #1
    Ever since I networked my apartment with a vigor router, whenever I am in Terminal the local hostname is shown as Vigor11. I have a PowerMac G4 and an iBook and it occurs on both computers.

    At work on our eMac that we use as an email-server, this does not happen. However, when I bring my laptop to work and plug it in the network and open a terminal window the local hostname displayed is "Vigor11". When I take out the network cable and open a new Terminal window the host name is what it is supposed to be, "meike". As soon as I plug in the net cable and execute a command in the terminal it switches back to Vigor11. Does this have something to do with the fact that the eMac has a static IP address and the iMac dynamic?

    How can I avoid this? This may be causing problems when I try to set up MySQL on the machines when it tries to find the local hostname but doesn't match.

    Thank you!

    Nate
     
  2. Nik_Doof macrumors regular

    Joined:
    Sep 15, 2003
    Location:
    St Helens, UK
    #2
    Are you using a NAT setup on ur router, and DNS relay? I noticed that instead of using the assigned hostnames it does a RDNS lookup on your ip, if its in the 192/10/172 ranges ur router may return its name instead of a valid hostname.

    Dunno never had much experiance with vigors.
     
  3. tomf87 macrumors 65816

    tomf87

    Joined:
    Sep 10, 2003
    #3
    DHCP servers, systems that assign network configurations to clients, can also assign hostnames as well. They can even assign items such as browser home pages, domain names, and NetBIOS settings.

    I don't know where it can be changed on the Mac, but disable any sort of hostname changing via DHCP. Linux (SuSE 8 and 9) have this capability and it appears MacOS does too. The other option is to change the router at home so it doesn't pass out hostnames.
     

Share This Page