Problems After Replacing ibook Hard Drive

Discussion in 'PowerPC Macs' started by mjms4, Jul 7, 2006.

  1. macrumors newbie

    Joined:
    Apr 28, 2006
    #1
    i recently replaced a hitachi travelstar 30GB HD (model: IC25N030ATMR04-0) with a Fujitsu 6GB (model: MHK2060AT). the new hard drive doesn't seem to be working. when i turn on the computer the screen flashes gray twice then goes black, and the HD makes a consistant and rapid clicking sound.

    when i put in the old hard drive it still works, so i don't think i hurt the computer while working on it. could there be any other reason the new HD is not recognized?
     
  2. macrumors 65816

    yankeefan24

    Joined:
    Dec 24, 2005
    Location:
    NYC
    #2
    6GB or 60? 6 sounds extremely low and I don't think everything that you need will fit on that.

    EDIT: Ran the model number, it is a 6GB drive! Make sure that the OS and everything is installed on it. Also, if the drive is clicking, it may have failed or be broken.
     
  3. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    The clicking sounds like a broken drive but as well as checking there's an OS installed on it, have you formatted the drive? If you start off the Restore discs, do they recognise your drive and are they able to format it?

    By the way, FWFW, 6GB is probably too small for OSX to run properly, if at all. Obviously this isn't as relevant if you'll be running an older OS though. :)
     
  4. thread starter macrumors newbie

    Joined:
    Apr 28, 2006
    #4
    ibook problems

    thank you for you reply.

    i'm not really clear on the formatting process. i tried booting the computer with the startup disks (2002 version). is there a step i've missed?

    i put in a 6GB hard drive because i wasn't actually sure i'd be able to successfully replace the HD, so i didn't want to purchase anyting too expensive.

    thank you for you time,
    m.
     
  5. macrumors 65816

    yankeefan24

    Joined:
    Dec 24, 2005
    Location:
    NYC
    #5
    I am saying that the drive has failed. If there is a warrantee, try to get a new one, if you bought it from ebay or somewhere else used, you were possibly scammed.

    Put the disks in and hold up 'd' at startup. Run the disk utility from the menu bar and click verify. See what it says. Also, just to refresh my memory, what OS was out in 2002?
     
  6. thread starter macrumors newbie

    Joined:
    Apr 28, 2006
    #6
    ibook problems

    version 10.2

    the same problem presists when i tried the 'd' button. i guess it is the hard drive. i bought it new form ifixit.com, i can't believe they sent me a ****** HD.
     

Share This Page