Problems connecting the Wii to the internet

Discussion in 'Community Discussion' started by sergeantmudd, Nov 19, 2006.

  1. sergeantmudd macrumors member

    Joined:
    Apr 21, 2002
    #1
    So I have an Airport card in my G4 tower and I just got a Wii a few hours ago. Wii has wireless internet, so I just turned on internet sharing and thought I was good to go. Nope, Wii wouldn't connect. (to the internet, it connects to the wireless network) I don't have a firewall on or anything. Is airport sharing in OS X usually problematic or does it behave the exact same as a real router? Anyone else experience the same thing? Error code 52030?
     
  2. gblass macrumors newbie

    Joined:
    Nov 20, 2006
    #2
    imac internet sharing orver airport

    i have tried the same thing, enabled the internet sharing over airport, I can identitfy the ssid, i can even set a wep key, but when it goes to test, it fails, i get thesame error, any help will be great
     
  3. gblass macrumors newbie

    Joined:
    Nov 20, 2006
    #3
    the solution it works

    With the recent release of Mario Kart DS and Tony Hawk: American Sk8land, Nintendo has launched its new WiFi service. If you've got an OS X box with internet access (other than through the AirPort card), and an AirPort card to transmit from, you can get online in no time.

    Read on for a step-by-step guide that should have enough detail to be followed by a networking novice...

    Here's how to use your Mac to share your internet connection with your DS:

    1. Make sure you're connected to the internet via something other than the AirPort card (i.e. Ethernet).

    2. Turn on Internet Sharing:
    * Go to System Preferences, click on the Sharing icon, then click on the Internet tab.
    * Change the Share your connection from: pop-up to 'Built-in Ethernet.'
    * Under the To computers using section, check the AirPort box.
    * Click Airport options...
    o Enter an easy name such as nds. Leave all the security options blank -- implementing security is an exercise left to the reader -- then click OK.
    * Click Start in the Internet Sharing panel.
    For sharing internet access with other computers, this is usually sufficient. However, the DS doesn't play well with the built-in DHCP server, so we have to manually configure the DS. To do this we, must gather some info...

    3. Gather Information:
    * Open Terminal.app and type ifconfig en1. In the output...
    o Look for: inet xxx.xxx.xxx.xxx netmask ...
    o Take note the IP Address (the x's) associated with the first inet (mine was 10.0.2.1; yours may be different).
    * Type dig. Near the bottom of this output will be SERVER: followed by an IP address. This will be the DNS server you will use for your DS.

    4. Configure the DS:
    * Edit your Nintendo Wi-Fi Connection Settings from within a compatible game.
    * Select a connection to edit.
    * Choose Manual Setup.
    * Enter the following parameters:
    o SSID: nds (or whatever you chose in step one)
    o Auto-obtain IP Address: No
    o IP Address: Take the first IP Address you obtained earlier, and make the last digit bigger. i.e., mine could be 10.0.2.4
    o Subnet mask: 255.255.255.0
    o Gateway: The first IP Address, unchanged. (e.g. 10.0.2.1)
    o Auto-obtain DNS: No
    o Primary DNS: your DNS SERVER from the earlier dig output.
    * Test your connection at the top of the screen. You should have no problem connecting.

    That's it, now just have fun!

    This hint was tested in Panther and Tiger, and the following links were very helpful in compiling this guide:
     
  4. magnaccio macrumors newbie

    Joined:
    Nov 21, 2006
    #4
    Wii walk thru

    This is an awesome walk-thru and all..but it doesn't really address with the "Wii" portion of the question. A DS is irrelevant at this point as the setup screens on the Wii are completly different. Don't know about everyone else, but i can't stop getting the 51030 error code, and on nintendo's website, i just get caught in a loop. and regardless of how many times i check my SSID, it's correct. :mad:

    frustrated. i want the vc, dangit!! :confused:
     
  5. magnaccio macrumors newbie

    Joined:
    Nov 21, 2006
    #5
    (to be more specific)

    i guess the only parameters this walk thru doesn't cover in reference to the wii are;

    Default Router:
    MTU Value:
    Secondary DNS:

    (and also, with the Primary, mine comes out "68.87.85.98#53(68.87.85.98)", am i just putting the first 4 groups of numbers in?

    any ideas at all?
     
  6. nicgeo macrumors newbie

    Joined:
    May 5, 2005
    #6
    Wii Solution

    So I tried out the DS instructions on my Powerbook G4 to connect to the Wii.

    For the items on the Wii not listed in the DS instructions I used:

    Default Router: Using the Gateway numbers from the solutions post
    MTU Value: 0
    Secondary DNS: left as 000.000.000.000

    And it worked.

    And Yes I just used the first 4 numbers for the Primary.
     
  7. magnaccio macrumors newbie

    Joined:
    Nov 21, 2006
    #7
    Argh!

    wish i could say the same. following these instructions all the way down the line, i still get the 51030 error. so wish there was a 1800 number somewhere on their tech site. of course they would blame apple, and apple would blame them..etc....etc....etc.

    oh well...toiling away.
     
  8. bracersofint macrumors newbie

    Joined:
    Nov 22, 2006
    #8
    o my! it worked!

    updated wii AirPort instructions:
    1. Make sure you're connected to the internet via something other than the AirPort card (i.e. Ethernet). Also, make sure AirPort is on.

    2. Turn on Internet Sharing:
    * Go to System Preferences, click on the Sharing icon, then click on the Internet tab.
    * Change the Share your connection from: pop-up to 'Built-in Ethernet.'
    * Under the To computers using section, check the AirPort box.
    * Click Airport options...
    * Enter an easy name such as wii. Leave all the security options blank -- implementing security is an exercise left to the reader -- then click OK.
    * Click Start in the Internet Sharing panel.

    3. Gather Information:
    * Open Terminal.app and type ifconfig en1. In the output...
    * Look for: inet xxx.xxx.xxx.xxx netmask ...
    * Take note the IP Address associated with the first inet, negating values after the # (mine was 10.0.2.1; yours may be different).
    * Type dig. Near the bottom of this output will be SERVER: followed by an IP address. This will be the DNS server you will use for your wii.

    4. Configure the wii:
    * Select a connection to edit.
    * Choose Manual Setup.
    * Enter the following parameters:
    * SSID: wii (or whatever you chose in step one)
    * Auto-obtain IP Address: No
    * IP Address: Take the first IP Address you obtained earlier, and make the last digit different. i.e., mine could be 10.0.2.4 (10.0.2.1 was original)
    * Subnet mask: 255.255.255.0
    * Default router: The original IP Address, unchanged. (10.0.2.1)
    * Auto-obtain DNS: No
    * Primary DNS: your DNS SERVER from the dig output.
    * Secondary DNS: leave as 000.000.000.000
    * Test your connection at the top of the screen. hope it works :)
     
  9. charpy30 macrumors newbie

    Joined:
    Nov 22, 2006
    #9
    Hi everyone.

    I'm new here and hope you guys will be able to help me.

    I have an airport express, a DS and a Wii....

    The DS connects without any problems to my airport... but it's different for the wii...

    I keep getting these error codes : 52030, 52031, 52130, etc...

    I think the problem resides in the fact that my ISP requires a PPPoE connection instead of a DHCP one... But I'm really not that sure.... Could be anything else...

    Does someone has any idea of what's going on?

    Thanks!
     
  10. charpy30 macrumors newbie

    Joined:
    Nov 22, 2006
    #10
    By the Way, I tried your setup... No good... At least, for me...
     
  11. magnaccio macrumors newbie

    Joined:
    Nov 21, 2006
    #11
    ditto...

    right there with all the 52130/1/2 peeps....:mad:
     
  12. germac macrumors newbie

    Joined:
    Dec 26, 2006
    #12
    Simple solution really

    I have to admit that I was quite frustrated when none of the suggested ways seemed to work. To save everybody some time, here is how it works:

    The wii does not support the way the Airport software transmits your password.

    Open your Airport Administration and select Password in the top menu. This will give you an alternate password for non-Apple equipment such as the wii.

    Enter the password in your wii settings. Do not change anything else manually. You're connected. The wii will now update its firmware or whatever.

    That's it.
     
  13. danibo77 macrumors newbie

    Joined:
    Jan 4, 2007
    Location:
    Oslo, Norway
    #13
    Remark on the guide

    I had serious problems connecting the wii to my built-in imac wireless..

    Followed the guide, but no help..UNTIL I saw one little sentence that i had overlooked:

    In the IP setting, the IP Address should have the LAST DIGIT bigger by 1.

    That is, if it's originally 10.0.2.1, you should write 10.0.2.2.

    Voila, and it worked flawlessly!!

    AND DON'T FORGET TO READ AND AGREE TO THE CONTRACT IN THE INTERNET-SETTINGS AFTERWARDS.


    That cured my "forever-and-ever-loading-and-hang-wii-shop-channel-syndrome"

    :)
     
  14. linds0r macrumors newbie

    Joined:
    Jan 22, 2007
    #14
    Thank You

    TOTALLY WORKED FOR ME. I registered just to tell you how thankful I am!!!

    Awesomely awesomeness.
     
  15. ropeswing macrumors newbie

    Joined:
    Jan 18, 2007
    #15
    That did it for me! Thanks a million.
     
  16. gomacos macrumors newbie

    Joined:
    Jan 27, 2007
    #16
    iMac G4

    I am having all of the problems described above. 51030, 52130, 52131 errors. I am using an older imac with an original airport card. Is this not compatible?
     
  17. vtuniversal macrumors newbie

    Joined:
    Jan 28, 2007
    #17
    Works great. thanks!

    After it's all setup you can go back into Airport Options and set the password, and then set it manually on the wii.
     
  18. gtm3q macrumors newbie

    Joined:
    Feb 3, 2007
    #18
    My problem is getting the DNS Server number.

    I follow these directions but I cannot get a DNS server number. When I type dig into the terminal app it will not connect to a server. Any suggestions?


     
  19. purefuel99 macrumors newbie

    Joined:
    Feb 16, 2007
    #19
    This solution worked for my airport express and wii

    Here's the combo that works for me with me Wii and Airport Express:

    Open up the Airport Admin Utility and set the router to this:

    Wireless Security: WAP2 Personal (Set it to WAP2 ONLY)
    Channel: 11

    then click on the port mapping tab and add: 10.0.1.253 as the private IP address.

    then do the normal setup on the Wii
     
  20. spruce macrumors newbie

    Joined:
    Feb 18, 2007
    #20
    Suddenly Lost Connection

    I followed these instructions about a month or so ago and my Wii was connected beautifully. But, the other night, all of a sudded we lost the connection. I don't know what happened. Any ideas on what could be causing the problem? I get error code 50100 when trying to test the connection now. I searched and there are 4 or 5 other wireless networks in the area that the Wii is also picking up. Do you think this could be the problem? Thanks so much for anyone who might have some suggestions!!
     
  21. CinemaGuy1 macrumors newbie

    Joined:
    Feb 26, 2007
    #21
    Everything you guys are saying is helping me tremendously here, but I have one issue I would like to address. When I go into internet sharing mode and type "dig" into terminal, it can't find any servers for my DNS information. I do have an IP number in sharing mode, so I'm ok there.

    While not in sharing mode, however, I have a number. What am I doing wrong to NOT have a DNS server number while in internet sharing mode?
     
  22. ghall macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #22
    1. Shouldn't this be in the gaming forums? :confused:

    2. I had the same problem. I found it only works if the Mac is within a foot or two of the Wii. Kinda sucks, and defeats the purpose of wireless, but it gets the job done.
     
  23. longtimenosee macrumors newbie

    Joined:
    Apr 1, 2007
    #23
    Wii Wireless Internet Connection With WEP Encryption

    Hey All,

    After much "googling" and testing I finally found out how to get your Mac Wireless Network up and running with a WEP encryption in place.

    This is mostly based on text from bracersofint :
    1. Make sure you're connected to the internet via something other than the AirPort card (i.e. Ethernet). Also, make sure AirPort is on.

    2. Turn on Internet Sharing:
    * Go to System Preferences, click on the Sharing icon, then click on the Internet tab.
    * Change the Share your connection from: pop-up to 'Built-in Ethernet.'
    * Under the To computers using section, check the AirPort box.
    * Click Airport options...
    * Enter an easy name such as wii. Use any password that fits your setting (i.e. 128 bit WEP requires 13 characters)
    * Click Start in the Internet Sharing panel.

    3. Gather Information:
    * Open Terminal.app and type ifconfig en1. In the output...
    * Look for: inet xxx.xxx.xxx.xxx netmask ...
    * Take note the IP Address associated with the first inet, negating values after the # (mine was 10.0.2.1; yours may be different).
    * Type dig. Near the bottom of this output will be SERVER: followed by an IP address. This will be the DNS server you will use for your wii.
    * Go to http://centricle.com/tools/ascii-hex/ and enter you password in ascii to get the %-separated hex-equivalent (should be 26 hex character for 13 ascii character with 128 bit WEP)

    4. Configure the wii:
    * Select a connection to edit.
    * Choose Manual Setup.
    * Enter the following parameters:
    * SSID: wii (or whatever you chose in step one)
    * Password: enter the hex equivalent of your password
    * Auto-obtain IP Address: No
    * IP Address: Take the first IP Address you obtained earlier, and make the last digit different. i.e., mine could be 10.0.2.4 (10.0.2.1 was original)
    * Subnet mask: 255.255.255.0
    * Default router: The original IP Address, unchanged. (10.0.2.1)
    * Auto-obtain DNS: No
    * Primary DNS: your DNS SERVER from the dig output.
    * Secondary DNS: leave as 000.000.000.000
    * Test your connection at the top of the screen.

    This should work...and you should see successful test results from the Wii.

    Next, go to News Channel and check to see if it works... if not go back and make sure you followed all steps.

    Peace

    LTNS:)
     
  24. PAX112 macrumors newbie

    Joined:
    Apr 23, 2007
    #24
    Really Works

    Simple solution really
    I have to admit that I was quite frustrated when none of the suggested ways seemed to work. To save everybody some time, here is how it works:

    The wii does not support the way the Airport software transmits your password.

    Open your Airport Administration and select Password in the top menu. This will give you an alternate password for non-Apple equipment such as the wii.

    Enter the password in your wii settings. Do not change anything else manually. You're connected. The wii will now update its firmware or whatever.

    That's it.




    AWESOME!!!! THANKS!!! This REALLY WORKS. I suggest everyone tries this.
     
  25. ChazzO macrumors newbie

    Joined:
    Aug 3, 2007
    #25
    Perfect!! Cheers.

    Though to note:

    It wouldn't work for me until I unblocked UPnP traffic in the firewall settings.
     

Share This Page