1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Problems upgrading Tiger to Leopard on iMacG5

Discussion in 'PowerPC Macs' started by kipperpainter, Jan 28, 2010.

  1. macrumors newbie

    #1
    Hi, I have an iMac G5 17" with 2GHz PowerPC G5 processor , originally had 512 MB RAM and has been upgraded to 2Gb RAM. The HD has been erased apart from the Tiger OS. I assume there is now 1Gb RAM in each slot ... not sure if the original 512 MB was split between two slots or if it was all in one slot. Have been using OS Tiger 10.4 up until now.

    Recently I bought a RETAIL edition of Leopard 10.5.1 to install ( the one with the big X on the front) but after 10 minutes of the installation got the message "Install Failed ... Source Media Disc damaged" . I previously tried another Leopard installation disc and got the same message. I think it's unlikely that both installation discs are damaged; they are both new and came from reputable sources. I can reinstall Tiger without any problems. I have tried erasing the HD volume using Disc Utilities at the initial install stage but still get the same message .

    A colleague has now advised me there have been problems with some iMac G5 machines with upgraded RAM when trying to install Leopard ... the Leopard installation disc does not like upgraded RAM.

    Before I try and source some RAM to the original spec. ie 512MB, and then try again with Leopard, can anyone advise me if it might be worth taking out just one of the existing 1 Gb RAM modules ( I assume there are two there, I dont know for sure because the upgrade was done by a Mac Repair Shop ) and then trying the Leopard Install with just 1Gb RAM ? Or do I need to go back to the original 512Mb module(s) ?

    Thanks for reading and hope you can help.

    Cheers

    dunk in Peterborough UK
     
  2. macrumors 68040

    MacHamster68

    #2
    i would suggest to put in your tiger install cd 1 holding down the D before you start and keep on holding it and run hardware test (extended test or how its called , cant remember now ) which checks the ram , takes long time , but if there is the slightest problem you got the source of the problem
     
  3. macrumors newbie

    #3
    Thanks, I'll try that later .. I just ran a "Crucial RAM Scan" which confirms there are two separate 1GB RAM modules installed.

    Cheers

    dunk
     
  4. macrumors newbie

    #4
    Here are the diagnostic results:

    [​IMG]
    [​IMG]

    Thus seems to be a RAM problem ... Now waiting for some replacement RAM modules which hopefully should resolve the matter.

    Many thanks for your suggestion.

    Cheers

    dunk
     
  5. macrumors member

    #5
    I had the exact same problem with an almost identical machine (mine shipped with 1 GB of RAM- 2 512 MB sticks). I had 2 GB of RAM installed from a 3rd party vendor, which went bad, triggering a cascade of problems. I sent the RAM back to the manufacturer (Crucial) and received a replacement kit less than a week later.

    I resolved it by replacing the new RAM with the original that shipped with the computer, wiping the drive, re-installing Tiger, re-installing Leopard, and then adding the replacement 2 GB RAM kit.

    I hope that helps.
     

Share This Page