Problems with Airplay in nPlayer?

Discussion in 'iPad Apps' started by Davidkoh, Oct 11, 2013.

  1. macrumors 65816

    Joined:
    Aug 2, 2008
    #1
    Hey.

    Since iOS 7 I noticed that when I airplay with nPlayer I get audio only and I am wondering if anyone else noticed this problem? I cannot remember I had this problem before the update when I first tested airplay.
     
  2. macrumors 603

    Joined:
    Jun 7, 2011
    #2
    You must have switched to "Hardware" or "Software" decoding mode from the default "QuickTime". Then, if you don't enable mirroring (and, with AirPlay & video playback, you NEVER should), there will only be audio output.

    I've written a mini-tutorial on switching between these decoding modes (also) in my latest nPlayer review here at MR: http://forums.macrumors.com/showthread.php?t=1652736 (see the first three screenshots in Section 2).

    All this assumes you're trying to play back native iOS videos - that is, mov / mp4 / m4v files.
     
  3. macrumors 603

    Joined:
    Jun 7, 2011
    #3
    Posted a more thorough elaboration in the original thread - see http://forums.macrumors.com/showpost.php?p=18122436&postcount=2
     
  4. thread starter macrumors 65816

    Joined:
    Aug 2, 2008
    #4
    Apparently I only have this problem when streaming it, if the files are on the iPad I do not.
     
  5. macrumors 603

    Joined:
    Jun 7, 2011
    #5
    Streaming from what kind of source?

    UPnP: HW playback works just great assuming
    - QuickTime decoding (NOT HW or SW!)
    - iOS-native file formats

    SMB: with iOS-native file formats, no QuickTime playback possible (HW is, but it still can't be sent over AirPlay). That is, if you have SMB but your source also supports UPnP, switch to UPnP.

    Please also note that

    1, I've published several articles here at MR on SMB / UPnP streaming, including even AirPlay
    2, I've just posted an updated version of the above-linked review of three apps
     

Share This Page