Problems with KDE

Discussion in 'Mac Apps and Mac App Store' started by 5300cs, Apr 5, 2004.

  1. 5300cs macrumors 68000

    5300cs

    Joined:
    Nov 24, 2002
    Location:
    japan
    #1
    I installed the KDE-bundle package from Fink, it installed and all that, but when I startup KDE, I cannot click on anything within KDE. The tip window comes up, but no mouse clicks register.
    Everything else works fine, just KDE won't.
    Anyone know how to fix this? I searched the forums, but didn't find any answers .. :confused: :(
     
  2. 5300cs thread starter macrumors 68000

    5300cs

    Joined:
    Nov 24, 2002
    Location:
    japan
  3. stuffaround macrumors newbie

    Joined:
    Apr 28, 2004
    Location:
    Joburg, South Africa
    #3
    Same problem!

    I've got the same problem! I've installed Gnome and that works nicely- normally or full screen - and a bunch of other apps, but I can't seem to get KDE to work ok. I'm going to reinstall it and see if that works...

    I also have a feeling it's linked to the Wizard that came up when I first ran KDE - asked for a bunch of preferences, and one of them was something to do with the behaviour of KDE - did I want it to be X11/Unix/Macintosh (or something like that). I chose "Mac" - I don't know if that is maybe the problem? I can't seem to find that wizard any more...
     
  4. stuffaround macrumors newbie

    Joined:
    Apr 28, 2004
    Location:
    Joburg, South Africa
    #4
    kwin won't run if it's not already set as the window manager

    Going through the log file generated by
    /sw/bin/startkde >/tmp/kde.log 2>&1
    in my .xinitrc file, there's a line that reads:

    kwin: it looks like there's already a window manager running. kwin not started.

    Ahha! So if we use the default quart-wm window manager, kwin (KDE's window manager) won't start. So all we need to do is to edit the .xinitrc file and tell X11 that we want kwin to be the window manager.

    It's to do with changing your .xinitrc file (in your Users/username directory) - what's worked for me is:

    source /sw/bin/init.sh
    export KDEWM=kwin
    exec /sw/bin/kwin
    /sw/bin/startkde >/tmp/kde.log 2>&1

    Voila! KDE starts when you start X11. I don't know how to get KDE to start seperately of X11 - in a terminal command. Executing startkde seperately in an xterm crashes X11.
     

Share This Page