Problems with Logic 9 & BOSS GT-10

Discussion in 'Digital Audio' started by MinuNianda, May 21, 2011.

  1. macrumors newbie

    May 21, 2011
    Not sure if there is another thread on this, hopefully someone can direct me to the right one. Recently acquired Logic 9 for my MacBook Pro. I want to record guitar tracks and export them and import them into ProTools.

    The issue:

    I am connecting my BOSS GT-10 Guitar Effects Processor through MIDI via USB. My Mac and Logic recognizes the MIDI interface, however, there's no sound in the Output. Can anyone help me out in this? I have projects that I need to work on and time is money.
  2. macrumors 603


    Dec 31, 2002
    Green and pleasant land
    It sounds like you're expecting sound to be transmitted over Midi? (Which of course it won't).

    Does the GT10 contain an audio interface too - and have you assigned it to a track so that you can record it?
  3. macrumors 6502a

    Mar 26, 2010
    You need to go Guitar > Boss > Soundcard.

    Set it up the same way you would plug into an amp except the cable goes into a soundcard / audio interface instead of an amp!!

    MIDI is not sound!!!

    I use an Apogee Duet to get my guitar sounds into logic
  4. macrumors newbie

    Jul 4, 2011
    hi, unsure if it is still an issue, but i'll walk through exactly how i've set mine up just incase. :)

    - GT10 into USB port of macbook
    - plug in guitar as normally would through an amp etc
    - check on the GT10, system > USB... driver mode: standard, monitor cmd: disable, dir. monitor: on (other settings may work, this is just what i see)

    - in logic, set the input on the audio track to unput 1 and check in preferences > audio that input is GT10 and output is usually built in output (unless you have a separate output)
    - arm the track in record or monitor (the orange 'i' symbol)

    i can't think of anything else that could be altered, nor any reason why it doesn't work. if it still doesn't, i can go into more detail if necessary.
  5. macrumors newbie

    Feb 23, 2013

Share This Page