Problems with MySQL in Tiger

Discussion in 'macOS' started by vawolf, Jul 10, 2005.

  1. vawolf macrumors member

    Joined:
    Jun 3, 2004
    #1
    I didn't find a thread this addressed this exactly, so apologies if there is one.

    I wanted to install MySQL 4.0.24 so I could follow this MacZealots tutorial on WordPress. I deleted whatever MySQL package (file name looked something like: "mysql-standard-4.x.xx-apple-darwin7.7.0-powerpc") was under the /usr/local, as well as the mysql directory in there using the REMOVE command. Then I tried to install mysql-standard-4.0.24-apple-darwin7.7.0-powerpc from mysql.org. The installation failed: I got an error message that said I had a newer version of MySQL.

    How can I get this package to install? Do I need to delete the MySQL directory located under Library/MySQL? I deleted MAMP and that didn't help. I also have SQL4X Manager J installed, but as I understand it that only communicates with databases, it doesn't install MySQL. :confused:
     
  2. wrc fan macrumors 65816

    wrc fan

    Joined:
    Jan 19, 2003
    Location:
    In a world where LPs are made like pancakes
    #2
    You'll want to delete the package under the /Library/Receipts directory.
     
  3. vawolf thread starter macrumors member

    Joined:
    Jun 3, 2004
    #3
    Thanks!

    This worked. I was able to install the package with no problem. Thanks!

    Are those receipts something I should clear out regularly?
     
  4. wrc fan macrumors 65816

    wrc fan

    Joined:
    Jan 19, 2003
    Location:
    In a world where LPs are made like pancakes
    #4
    No, you only want to clear that out when you want to reinstall something that you know has been removed correctly (for the most part) but the installer won't let you reinstall. It is used so software knows something has been installed and to run an upgrade on it (like in Software Update).
     
  5. vawolf thread starter macrumors member

    Joined:
    Jun 3, 2004

Share This Page