Problems with Security Update 2004-06-07

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Wren, Jun 10, 2004.

  1. Wren macrumors regular

    Joined:
    Dec 10, 2002
    Location:
    Los Angeles
    #1
    I installed the software update on iBook running on Panther and after downloading and restarting the computer, it stalled at the point where it says"Waiting for Printing Services "( 95% of startup ). I've tried restarting the computing several times and it always stalls up to this point. Anybody else having this problem? HELP!
     
  2. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #2
    nope.no problems for me. try booting in the safe mode.
     
  3. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #3
    Try booting in "verbose mode", you might be "told" what is wrong.

    Get into verbose mode by holding down the <COMMAND> and <V> right after startup chime. Press and hold until grey boot screen turns into black with white letters.

    Read 'em! You might get wiser. ;)
     
  4. Darwin macrumors 65816

    Darwin

    Joined:
    Jun 2, 2003
    Location:
    round the corner
    #4
    Could this be linked to the System accessing the Printing Services?
     
  5. hann0 macrumors newbie

    Joined:
    Jul 7, 2004
    #5
    Likewise.

    I am having exactly the same problem.

    I have not had time to research it properly, but I have seen that this Update changes something in /etc/cups/cupsd.conf.

    Restored previous version (in single user mode), rebooted, no go.

    Also, dyld complains about a wrong version of libxml.

    Any suggestions as to what might be wrong?

    (And yes, I know that the 'mac way' of fixing it is probably the fastest ("Archive and install") - I just prefer to know what is going on)

    Han (unix sysadmin)
     
  6. hann0 macrumors newbie

    Joined:
    Jul 7, 2004
    #6
    Bingo.

    update:

    - Tried starting cupsd manually, fails on error 49.
    - Started cupsd manually, in the foreground (so I can see what is going on)
    - dyld again- "version mismatch for library [...] /usr/lib/libxml2.2.dylib"

    So it definitely seems to be that library.

    ...

    Han
     

Share This Page