${PRODUCT_NAME} appearing in iTunes and under icon?

Discussion in 'iPhone/iPad Programming' started by Locker, Mar 9, 2009.

  1. macrumors 6502

    Joined:
    Aug 22, 2007
    Location:
    Staffordshire, UK
    #1
    I've just created an Adhoc target and made info.plist a member of it. The problem is that since I've done this the icon name has literally become '${PRODUCT_NAME}'. This shows up under the icon on the iPhone (I'm only using the simulator) and also when the app is dragged into iTunes.

    I'm pretty new to all of this, so am I missing something obvious?
     
  2. macrumors member

    Joined:
    Oct 2, 2008
    #2
    info.plist

    you will find this in your info file in xcode open that up and change the display name
     
  3. thread starter macrumors 6502

    Joined:
    Aug 22, 2007
    Location:
    Staffordshire, UK
    #3
    I guessed that would work, but thought ${PRODUCT_NAME} was some sort of variable which should be left in because it references another 'master value' in the project. I just thought it wasn't parsing correctly.

    Is that not the case then? It does need changing?
     
  4. macrumors 6502a

    Joined:
    Oct 24, 2008
    Location:
    Cambridge
    #4
    It should be, unsure why it's not parsing. Maybe deleting from the device and iTunes followed by a Build > Clean will fix it?
     
  5. thread starter macrumors 6502

    Joined:
    Aug 22, 2007
    Location:
    Staffordshire, UK
    #5
    That seems to have worked, thanks :)
     

Share This Page