Programs opening in background

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by mkaake, Jul 15, 2004.

  1. mkaake macrumors 65816

    Joined:
    Apr 10, 2003
    Location:
    mi
    #1
    I've got a problem that I haven't found elsewhere here on the boards (which yes, means i've searched :) ), and i haven't gotten any help from the apple discussion boards...

    so here it is:

    recently, every time a program is opened, either by me directly or by double clicking a file associated with it or what have you, it opens up in the background. for the life of me, i have no idea if there's something i've accidentally turned on while plugging through the pref's. But I can't seem to find any documentation of how to turn it back off... and it's getting reallllly annoying... i mean, really annoying.

    any thoughts on what i can do?

    anyhew, 10.3.4, 1.0 emac, blah blah blah...

    matt
     
  2. crazzyeddie macrumors 68030

    crazzyeddie

    Joined:
    Dec 7, 2002
    Location:
    Florida, USA
    #2
    First try deleting the Finder plist (preferences) file. If that doesn't work, I would do an Archive and Install of 10.3.
     
  3. mkaake thread starter macrumors 65816

    Joined:
    Apr 10, 2003
    Location:
    mi
    #3
    i've narrowed it down a little bit... the finder plist didn't do it, and i think re-installing the system might be a little bit drastic for programs opening in the background... :rolleyes:

    i think i've narrowed it down to the systempreferences.plist... more specifically, the ShowAllMode - if I set it to yes, everything opens the way it should. If I set it to no, things open in the background. But if I do have it set to yes, I loose all organization on the preference pane itself - they're all lumped together in no specific order w/o any of the graphical divisions that existed before.

    but, as it sits, with this problem, i've been experiencing on and off problems w/my mouse... the center click (on the scroll wheel) sometimes doesn't work (assigned to expose - which is why i started actually using it, and got addicted), and sometimes the pointers don't keep up with what i'm doing - i sometimes need to click once or twice to get the pointer I should have.

    strange.

    any more thoughts out there?

    matt
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Sounds to me like a reinstall of Mac OS X would do you and your Mac a world of good. The best way to reinstall, if you want to be absolutely sure that the cause of the problem is gone, is to back up everything in your home folder EXCEPT the ~/Library/Preferences folder, then do an erase and install of Mac OS X, then install all the updates and restore your data.
     
  5. mkaake thread starter macrumors 65816

    Joined:
    Apr 10, 2003
    Location:
    mi
    #5
    after a little bit of workin around, i have it all back to normal.

    i still don't quite know... it just seems to me like its a little overkill to get on the path of saying: you have a problem (small problem), so you should re-install your system...

    sounds a little too windows like to me...

    maybe what i'll do is create a new install on my partition and make a cd of the pref's folder so when in doubt, i can start fresh.

    that said, i could always just erase every single preference i have, and they'll be created as i need them, but things seem to be working just fine now...

    now if only i could figure out why sometimes my machine only has 17 megs of ram available (at idle with no programs running) while at other times, its 117... and there's no 'big hitter' in the activity monitor. freakin me out... although maybe i'll care less once i scrape together the cash for that stick of 512 for the beastie...

    matt
     
  6. GaseousPlatypus macrumors member

    Joined:
    Jul 8, 2004
    #6
    Erm, so what was the solution, since I just started having this problem too :mad:
     
  7. mkaake thread starter macrumors 65816

    Joined:
    Apr 10, 2003
    Location:
    mi
    #7
    do you have the developer tools installed? or at least the CD so you can install them w/o a huge download?

    if you do, it's pretty simple. what you do is open up the system pref's plist, and change the 'ShowAllMode' to No. not sure how familiar you are with your system, but that's located in your user folder, library, preferences, com.apple.systempreferences.plist

    once you change the value to 'no', it rearranged my system prefs to no order... no biggie there... under system preferences change the option under the 'view' menu to organize by categories.

    this worked for me, hope it works out well for you.

    matt
     
  8. GaseousPlatypus macrumors member

    Joined:
    Jul 8, 2004
  9. mkaake thread starter macrumors 65816

    Joined:
    Apr 10, 2003
    Location:
    mi
    #9
    no prob. :) glad it worked for you too :)
     

Share This Page