PSSliderSpecifier minimum/maximumValueImages

Discussion in 'iOS Programming' started by RossOliver, Aug 4, 2008.

  1. macrumors regular

    Nov 6, 2006

    I've been baffled by this for a few weeks now and I just can't figure out how to get the minimum/maximumValueImage to appear for a Settings.bundle PSSliderSpecifier.

    I add a correctly sized png image to my MyProg/Images group, then put the filename into the minimum/maximumValueImage option of my Settings.bundle Root.plist file:

    I can't understand where I can be going wrong - I've tried resetting the iPhone Simulator and that doesn't appear to make a difference... I also have the latest iPhone SDK.

    If anyone can help me out I would appreciate it :)

    Thanks for your time,

  2. thread starter macrumors regular

    Nov 6, 2006
    Any ideas? Has anyone managed to get a minimum/maximumValueImage for a PSSliderSpecifier working?
  3. macrumors newbie

    Sep 29, 2004
    PSSliderSpecifier minimum/maximumValue Images how-to

    To get the MinimumValueImage and MaximumValueImage to work with PSSliderSpecifier, I had to open the Settings.bundle in the Finder using "Show Package Contents" and copy the png files in there.

    Size didn't seem to make a difference, smaller ones worked OK. The image files need to be in the Settings.bundle. I could not get them in there using Xcode, had to do it by hand.
  4. thread starter macrumors regular

    Nov 6, 2006
    Ah, yea I discovered the same thing :) - was a bit of a pain really... I would have thought it would be possible from within XCode :confused:


Share This Page