Push notifications not working on iPhone 4S 6.1

Discussion in 'iOS 6' started by worldsdream, Feb 9, 2013.

  1. worldsdream, Feb 9, 2013
    Last edited: Feb 9, 2013

    worldsdream
    Expand Collapse
    macrumors newbie

    Joined:
    Feb 9, 2013
    #1
    Hi all,

    I have an iphone 4s with 6.1 installed. fresh installed. no jailbreak. i did put viber and whatsapp on it. I dont use 3g network. Only wifi. I cant get push notifications. I have it enabled in the settings->notifications.
    push mail is working. imessage isnt working, but its activated in the settings->messages.

    it was all working great on 5.1.1

    anyone that can help me with this? much appreciated.

    update: i did restart my router. still push isnt working.
    update: i installed ipusher app on appstore and it doesnt give me a push notification that says, push notifications work fine!
     
  2. Am3r1ca16
    Expand Collapse
    macrumors 6502a

    Am3r1ca16

    Joined:
    Jul 17, 2012
    Location:
    New York City
    #2
    fresh restore without backup should fix push notification
     
  3. worldsdream
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Feb 9, 2013
    #3
    thanks for your reply. i already did that. i did fresh restore. setup as new iphone. only installed viber and whatsapp. both dont get push notifications. imessage isnt sending messages.
     
  4. IManuB
    Expand Collapse
    macrumors newbie

    Joined:
    Feb 9, 2013
  5. worldsdream
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Feb 9, 2013
    #5
    thanks for the reply. i did that right now. its still not working.
     
  6. Mikansei
    Expand Collapse
    macrumors newbie

    Joined:
    Feb 10, 2013
    #6
    I have the same problem with push notifications.
    However, I'm on an iPhone 4.
    I tried restoring it but to no avail, iPusher won't give me anything (while not being jailbroken nor hacktivated) :(.
     
  7. worldsdream
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Feb 9, 2013
    #7
    seems the same as me. does push notification work over 3g?
    even 3g enabled and wifi enabled will work. but only wifi enabled and 3g disabled wont work. agree?
    edit: I am also not hacktivated or jailbroken. fresh restore and setup as new phone.
     
  8. worldsdream
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Feb 9, 2013
    #8
    i went to a friend and push notifications are working on his wifi. i went to work. push notifications are working. it seems its a problem by my router. but it always worked on ios 4 and ios 5. is there a setting that i need to enable or disable or change on my router? my router is SpeedTouch 780.
     
  9. sbailey4
    Expand Collapse
    macrumors 65816

    sbailey4

    Joined:
    Dec 5, 2011
    #9
    Apple Push Info

    You need to check and see if you are blocking port 5223. Here is a document from Apple http://support.apple.com/kb/HT3576 See item 5 at the bottom of document.
     
  10. Ungibbed
    Expand Collapse
    macrumors 6502

    Ungibbed

    Joined:
    Dec 13, 2010
    Location:
    USA
    #10
    Push works okay for me save for one app over the past few iOS updates and even updates to the application itself.

    The offender... Facebook.
     
  11. IManuB
    Expand Collapse
    macrumors newbie

    Joined:
    Feb 9, 2013
  12. worldsdream
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Feb 9, 2013
    #12
    i just did update to 6.1.1 and its still not working

    ----------

    i went to the genius bar today. they said they never heard of it and they cant do anything about it.
     
  13. macatak, Apr 10, 2013
    Last edited: Apr 10, 2013

    macatak
    Expand Collapse
    macrumors newbie

    Joined:
    Mar 18, 2011

Share This Page