QT won't play HB output files

Discussion in 'Apple TV and Home Theater' started by dshlapak, Mar 26, 2013.

  1. macrumors newbie

    Joined:
    Mar 28, 2008
    #1
    Hello. Trying to rip my Blu-ray movies into iTunes. Using MakeMKV for the actual rip, then Handbrake to transcode into m4v/mp4. Problem: the file HB produces—after six or seven hours, and which is basically the same size as the input MKV—is unreadable by QuickTime. Says it's in an unplayable format. Changing the file extension from m4v to mp4 doesn't help.

    I'm sure I'm doing something simple and stupid wrong, and would appreciate any pointers as to what it might be.

    Thanks!
     
  2. macrumors 68020

    Joined:
    Mar 27, 2003
    #2
    which preset are you using ? Is large file size checked ?
     
  3. macrumors 68020

    Joined:
    Mar 15, 2012
    #3
    What version and what settings are you using in HB?
    Will the MKV play in VLC?
    Would you post MediaInfo (or Media Inspector) data on the file?
    What movie is it? Does this happen with all BR's or just a problem with an individual disc?

    Edit: Nevermind...I see the HB expert is on the case!!!
     
  4. thread starter macrumors newbie

    Joined:
    Mar 28, 2008
    #4
    I'm using the "Normal" preset, which leaves "Large file size" unchecked.

    I'm currently working on Saving Private Ryan, but I had the same problem with The Hurt Locker.

    The MKV does play in VLC.

    Using HB 0.9.8.

    Thanks.
     
  5. macrumors 68020

    Joined:
    Mar 27, 2003
    #5
    Well, I will presume your going over 4 GB and therefore you need to check Large file size. This creates a 64 bit mp4 which can be any size. Without it checked, if the file goes over 4 GB it will fail on muxing.

    An activity log posted on pastebin.com and linked here would show the failure on muxing.

    However if you are getting output files the size of a blu ray I am sure you are going waaay over 4 GB.

    ----------

    Also, if thats the case you might as well throw the files away you have done because there is no way to fix them after the fact. Gonna have to start over.

    Btw, why are you using the normal preset (which really shouldn't be creating a file the same size as the source file anyway) ?

    I might suggest the AppleTV 3 preset.
     
  6. thread starter macrumors newbie

    Joined:
    Mar 28, 2008
    #6
    I'll try the ATV 3 present. Will the resulting file work on an iPad as well?

    Thanks.
     
  7. macrumors regular

    Joined:
    Mar 21, 2010
    #7
    The Apple TV 2 preset will work on any ipad. Apple TV 3 preset depends on the source. If its a blu ray, then ipad 3 and 4 only. If its a dvd then any ipad. Basically, 1080P files can only be viewed on ipad 3 and 4 (the retina ipads). Use the Apple TV 2 preset to downgrade 1080 to 720P.
     
  8. thread starter macrumors newbie

    Joined:
    Mar 28, 2008
    #8
    Thanks. Very helpful.
     
  9. thread starter macrumors newbie

    Joined:
    Mar 28, 2008
    #9
    Ok, I'll check back in about five hours :)eek:) when the transcode should be complete. Thanks for your help.
     
  10. thread starter macrumors newbie

    Joined:
    Mar 28, 2008
    #10
    So, after how many hours...I discover that I apparently MKV'd and transcoded the wrong track off of the Blu-ray disk. But, the process worked, at least; I can watch the wrong thing. Next time, I'll take a peek at the MKV file before I commit it to Handbrake. That way, I'll only risk wasting an hour or so.

    Always assuming MakeMKV will read the disc the next time I try. It seems a peculiarly hit-or-miss thing.

    At some point, just buying everything again on iTunes is going to start looking like the easier option.:(
     
  11. macrumors 68020

    Joined:
    Mar 15, 2012
    #11
    You might try setting the minimum title length in MakeMKV preferences to 1500s. That should eliminate all but the main title (sometimes there are 2 titles. Like when there is a regular cut and a directors cut, but that's rare). I have not found MakeMKV to be "hit-or-miss" but you do have to look at the disc scan and make sure of things before making the mkv.
     
  12. thread starter macrumors newbie

    Joined:
    Mar 28, 2008
    #12
    There were two pretty much identical-looking tracks; I had a 50:50 shot...

    I seem to be the only person on earth for whom MakeMKV performs poorly. I'd say it successfully reads a Blu-ray disc about one time in 10. This evening, when I tried to rip the other track from the disc it had read just fine earlier, it failed six times running. I finally just gave up.
     
  13. macrumors regular

    Joined:
    Mar 21, 2010
    #13
    +1 on the above reply about setting the minimum title length to 1500s.

    That is wired that makemkv is failing. Which blu ray drive are you using? Do you have DASPI installed which is an optional install with makemkv?

    Try to back up the whole disc in make mkv. That option is the second icon on the top to the left. Dont forget to check mark the decrypt bitton. After you back up the whole disc then go to hand brake. It will be best to set hand brake to minimum 1500s too.

    ----------

    Also, If you make them into MKV's, you can play those mkv files on your computer to make sure that you have the correct title. You may waste 30 minutes ripping to your hard drive but you wont waste hours transcoding them.
     
  14. thread starter macrumors newbie

    Joined:
    Mar 28, 2008
    #14
    MakeMKV mostly just gives me an endless series of SCSI read errors. I thought I'd had done with SCSI read errors years ago.;) Every once in awhile it works, but by and large...nah.

    I do have DASPI installed; using an external Samsung drive.

    I'll try the backup trick. That will create a file that HB can grok?

    Roger the 1500sec setting.

    Thanks to everyone for their help, BTW.
     
  15. macrumors 68020

    Joined:
    Mar 15, 2012
    #15
    Just for clarity, you can only create a full backup of BR disc's, not dvd's.
     

Share This Page