Quad G5 not powering up...

Discussion in 'Mac Basics and Help' started by jod8301, May 24, 2006.

  1. jod8301 macrumors newbie

    Joined:
    Jun 6, 2005
    #1
    Hey all,

    I'm (well...was) running a Quad G5 and I came in today to discover the power off. When I tried to turn it back on, the main power light flashes and there is a loud click...but nothing else happens.

    Anyone have an idea as to what could be going on? Power supply and guesses?

    Thanks,

    John
     
  2. iGary Guest

    iGary

    Joined:
    May 26, 2004
    Location:
    Randy's House
    #2
    Unpluig the machine from the wall for about 10 minutes, then:


    Reset the SMU: Underneath the ram to the right is small SMU reset button. Power computer down, remove side cover, air baffle and fan assembly and press button once. Put machine back together and restart.
     
  3. jod8301 thread starter macrumors newbie

    Joined:
    Jun 6, 2005
    #3
    Thanks for the tip...but it was a no go. Tried it and the same thing happened.

    Push power...click...nothing. :(

    Poor Quad.
     
  4. monkeydo_jb macrumors 6502

    Joined:
    Apr 17, 2002
    Location:
    Columbia, MO
    #4
    How much memory do you have in it? If you have multiple sticks, try taking all out but one.
     
  5. jod8301 thread starter macrumors newbie

    Joined:
    Jun 6, 2005
    #5
    4GB...all pre-installed...would it matter which stick I leave in? Which slot should have the solo stick?
     
  6. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #6
    you need a minimum of 2 matching DIMMs in corresponding slots.
     
  7. jod8301 thread starter macrumors newbie

    Joined:
    Jun 6, 2005
    #7
    Yeah...I remembered that about 5 minutes after posting. Still a no go.

    To AppleCare I go.
     
  8. iGary Guest

    iGary

    Joined:
    May 26, 2004
    Location:
    Randy's House
    #8
    Good Luck.

    *sick to stomach thinking about Apple Care*
     
  9. Grimace macrumors 68040

    Grimace

    Joined:
    Feb 17, 2003
    Location:
    with Hamburglar.
    #9
    The Quads have been plagued with power supply troubles. :mad:
     
  10. jod8301 thread starter macrumors newbie

    Joined:
    Jun 6, 2005
    #10
    Well...the call went well. Told them what I had tried, they said it's probably the PSU. My boss is taking it into the Soho NYC store tonight for repair.

    Hope they get it running.

    Much thanks to you all for the support and suggestions.
     
  11. ToddW macrumors 6502a

    Joined:
    Feb 26, 2004
    #11
    sounds like a power supply problem to me. memory just wouldn't allow your computer not to power on. could also be a logic board issue. might check to see if there are any swelled caps on the logic board. more than likely a power supply issue. should be an easy fix (as i wait for igary's response)
     

Share This Page