Quicktime wont play audio

Discussion in 'Mac Apps and Mac App Store' started by semaja2, Jan 11, 2006.

  1. semaja2 macrumors 6502a

    Joined:
    Dec 12, 2005
    Location:
    Adelaide
    #1
    Hey guys for somereason my avi videos wont play the audio even tho they are mp3

    XviD 1.1b2, 624 x 352, Unknown
    MPEG Layer 3, Stereo, 48.000 kHz

    the video shows but not the audio, it seems odd the audio wont play tho since it is mp3
     
  2. kretzy macrumors 604

    kretzy

    Joined:
    Sep 11, 2004
    Location:
    Canberra, Australia
  3. Sdashiki macrumors 68040

    Sdashiki

    Joined:
    Aug 11, 2005
    Location:
    Behind the lens
    #3
    Since QT 7 I have a hard time with some audio stuff.

    I too have this problem, but solve it with my XBOX or VLC.

    Seems QT7 doesnt support the AC3 codec, which is retarded too.
     
  4. semaja2 thread starter macrumors 6502a

    Joined:
    Dec 12, 2005
    Location:
    Adelaide
    #4
    i am aware of things like VLC and stuff like that but i want to use Front row which uses QT not VLC
     
  5. kretzy macrumors 604

    kretzy

    Joined:
    Sep 11, 2004
    Location:
    Canberra, Australia
    #5
    Ah, I see. Maybe try having a look for different codecs or 3rd party apps that may allow you to do what you want.
     
  6. semaja2 thread starter macrumors 6502a

    Joined:
    Dec 12, 2005
    Location:
    Adelaide
    #6
    yeh its just i find it that QT shoud be able to lay mp3 natievly so why isnt it?
     
  7. Sdashiki macrumors 68040

    Sdashiki

    Joined:
    Aug 11, 2005
    Location:
    Behind the lens
    #7
    you would think so, but AVIs are just containers and who can you trust to tell you what it was encoded in when QT (which plays MP3s) isnt playing it.

    I get alot of "unknown Mpeg layer 3/4 audio codec" sometimes, but its almost always XXX related ::wink::
     
  8. semaja2 thread starter macrumors 6502a

    Joined:
    Dec 12, 2005
    Location:
    Adelaide
    #8
    lol these are not XXX related there shows which i got by means of legally... anywho yeh i really which this would work cuz i dont want to convert 200gigs to a format it can play
     
  9. mileslong macrumors 6502

    mileslong

    Joined:
    Apr 29, 2005
    Location:
    Newport Beach, CA
    #9
    my QT pro would play most with all the codecs i have installed but after installing the new QT yesterday it quit playing audio on some mpgs and crashes after playing any wmv files.
     
  10. The Void macrumors regular

    The Void

    Joined:
    Oct 29, 2003
    #10
    Try Divx tool for the mp3 AVIs. And you can get the AC3 component for QT here (click on 'Programming').

    The Void
    ................
    It's "Vid-ayy-oh!!"
     
  11. Boelman macrumors regular

    Joined:
    Jul 15, 2004
    #11
    I am running into the same problem as this guy is. Any comments would be greatly appreciated.
     
  12. Sdashiki macrumors 68040

    Sdashiki

    Joined:
    Aug 11, 2005
    Location:
    Behind the lens
    #12
    can you get this to work in QT7 (the latest version) cuz I cant.
     
  13. The Void macrumors regular

    The Void

    Joined:
    Oct 29, 2003
    #13
    Which? The AC3, yes. Make sure you quit & relaunch QT.
    Divx Tool works on some avis, not on others.
     
  14. Sdashiki macrumors 68040

    Sdashiki

    Joined:
    Aug 11, 2005
    Location:
    Behind the lens
    #14

    have you dled files labeled "AC3.5.1" or anything that claims to be AC3 with 5.1, cuz I am having static and cutting out issues with QT7 but not with VLC.
     
  15. Soulstorm macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #15
    It is a well known fact that Quicktime has a hard time playing any .avi file with mp3 audio. I don't know why this happens, but it does.

    Maybe you should download FFMpegX to convert the movie to a friendlier Quicktime format, and see what happens.
     

Share This Page