Radeon HD 5800 and MacPro

Discussion in 'Mac Pro' started by netkas, Jul 2, 2010.

  1. netkas
    Expand Collapse
    macrumors 6502a

    Joined:
    Oct 2, 2007
    #1
    There was drivers for radeon 5 series in macmini 10.6.4 image

    so let's try to use them :D


    ATI5000Controller.kext ATIRadeonX3000VADriver.bundle
    ATIFramebuffer.kext ATISupport.kext
    ATIRadeonX3000.kext
    ATIRadeonX3000GA.plugin
    ATIRadeonX3000GLDriver.bundle
     
  2. netkas
    Expand Collapse
    thread starter macrumors 6502a

    Joined:
    Oct 2, 2007
    #2
    Rominator, here it is, unpack and install kext, i'll try to prepare aty_init

    http://mirror.netkas.org/driver.tar.bz2

    got to go, ill be back in 2 hr

    I will need your bios dump, you clothes and you motorcycle

    we will need to try these framebuffers, lol, that's a lot

    Alouatta
    Baboon
    Colobus
    Douc
    Eulemur
    Galago
    Gliff
    Hoolock
    Kipunji
    Langur
    Uakari
    Vervet
     
  3. MacVidCards
    Expand Collapse
    macrumors 604

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #3

    Looks good already, the 5000 kext loaded with 5870 in.

    so it seems ready to "connect the dots"

    ill dump & attach the rom but my clothes and motorcycle remain

    some good news, looks like space on EEPROM for a larger ROM.
     

    Attached Files:

  4. netkas
    Expand Collapse
    thread starter macrumors 6502a

    Joined:
    Oct 2, 2007
    #4
    here is first version, it's Alouatta
     

    Attached Files:

  5. huscat
    Expand Collapse
    macrumors member

    Joined:
    Oct 25, 2009
    Location:
    Kansas City
    #5
    Ati 5870?

    so this will work in my i7 Hack now?
     
  6. Mackilroy
    Expand Collapse
    macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
  7. MacVidCards
    Expand Collapse
    macrumors 604

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #7
    OK...doesn't seem to have changed anything.

    BTW...how do I knw for sure that it has loaded ATY_Init?

    It never shows up in the Extensions list in Sys Prof, even when it is working.

    TO keep track of them as I test I want to have each have a different name...is "ATY_Init-3.kext" a valid name?

    Did a verbose boot...saw "ATY_Init loaded for card 9588"
    followed by "ATY_init quit" or something along these lines. 9588 being the 2600 I am using to run monitor...no mention of 5870
     
  8. netkas
    Expand Collapse
    thread starter macrumors 6502a

    Joined:
    Oct 2, 2007
    #8
    make ioreg dump and we will see if aty_init worked
     
  9. MacVidCards
    Expand Collapse
    macrumors 604

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #9
    attached
     

    Attached Files:

  10. netkas
    Expand Collapse
    thread starter macrumors 6502a

    Joined:
    Oct 2, 2007
    #10
    i see, it didnt even connect to device.

    >so this will work in my i7 Hack now?

    it's good to test it on both hack and mac.
     
  11. netkas
    Expand Collapse
    thread starter macrumors 6502a

    Joined:
    Oct 2, 2007
    #11
    >TO keep track of them as I test I want to have each have a different name...is "ATY_Init-3.kext" a valid name?

    don't rename them when you install them. maybe u got 2 versions installed, so only one of them worked.

    here is another version to try, same old fb name.
     
  12. Durendal
    Expand Collapse
    macrumors 6502

    Joined:
    Apr 12, 2003
    #12
    Dear Netkas,

    I love you. I wish I currently had a 5xxx series to card to lend in testing.
     
  13. Hafnium
    Expand Collapse
    macrumors newbie

    Joined:
    Apr 25, 2010
    #13
    I got a Radeon 5850 card.
    How can I help testing?

    Thank you in advance.
     
  14. MacVidCards
    Expand Collapse
    macrumors 604

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #14
    Tried renaming the 1st one, no change.

    Loaded this one (#2) and no apparent change.
     

    Attached Files:

  15. AHuxley
    Expand Collapse
    macrumors newbie

    Joined:
    Jul 19, 2007
    Location:
    Adelaide Australia
    #15
    I have a HIS 5770 in a 06 Mac Pro if this is any help.
     
  16. MacVidCards
    Expand Collapse
    macrumors 604

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #16
    You may as well install the drivers and try these kexts...though I think Netkas may be tuning them for 5870.
     
  17. Roman23
    Expand Collapse
    macrumors 6502

    Joined:
    Jun 12, 2010
    #17
    Ok, so does this mean now..

    The Ati Radeon 5870 or 58xx series will NOW officially work in the 2009,2008 mac pros? I should also add 2006-2007 as well, as ATI is the only company that gives a damn for those still on EFI32. Nvidia apparently doesn't, but I don't think this company is going to last too much longer as they are in SERIOUS financial trouble right now(nanofrog).
     
  18. MacVidCards
    Expand Collapse
    macrumors 604

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #18
    this isn't an ATI vs NVIDIA rant thread.

    and in point of fact, currently Fermi is running on Mac Pros, but NOT any Cypress, etc.

    now please go elsewhere
     
  19. Vylen
    Expand Collapse
    macrumors 65816

    Joined:
    Jun 3, 2010
    Location:
    Sydney, Australia
    #19
    =/

    This post is obsolete with the mod's deleting the previous posts.
     
  20. strausd
    Expand Collapse
    macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #20
    I don't really know much when it comes to GPUs, but does the finding of these drivers mean a bigger likely hood of the 5870 being the next high-end GPU for the MP?
     
  21. jav6454
    Expand Collapse
    macrumors G5

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #21
    Yes, it might be the case. Also, netkas found GTX 480 support on new OS X images, so that is also the other alternative.
     
  22. Durendal
    Expand Collapse
    macrumors 6502

    Joined:
    Apr 12, 2003
    #22
    Apple wouldn't have the drivers if they weren't going to use them. May not be the 5870, though. I've heard rumblings that we'll see 5750s in the next iMac. The driver technically works for any card in the series with the right prodding, so it doesn't really matter in the long run which gets officially used, just that one of 'em does.
     
  23. Vylen
    Expand Collapse
    macrumors 65816

    Joined:
    Jun 3, 2010
    Location:
    Sydney, Australia
    #23
    What has previous experience told us?

    Does anyone know what things were like pre-2009 with driver leaks?
     
  24. netkas
    Expand Collapse
    thread starter macrumors 6502a

    Joined:
    Oct 2, 2007
    #24
    found the error, it was a little typo, here is fixed.
     

    Attached Files:

  25. ghola
    Expand Collapse
    macrumors newbie

    Joined:
    Jul 3, 2010
    #25
    new here.

    I have a MSI MS-1727 laptop with a 5870, I'll be watching this thread for kexts to start a fresh Snow Leo install as soon as there are some 58xx kexts ready to be tested.

    Thanks
     

Share This Page