Rebuild LDAP database?

Discussion in 'Mac Apps and Mac App Store' started by madamimadam, Apr 15, 2004.

  1. madamimadam macrumors 65816


    Jan 3, 2002
    Anyway to do this? My db has cracked the ****s and won't let people authenticate or check mail. Opening Workgroup Manager gives an error "node couldn't be opened... type -14002" and I can't look at users. I've tried repairing permissions and fsck as well as turning off OpenDirectory and resetting it with a new db directory (obviously I'm keeping back ups of home user folders and db folder).

    I REALLY don't want to have to re-install the server... I'll be here all night if I do

    Things I have also recently done:
    upgraded to 10.3.3
    changed name of drive holding database from BackUp to LDAP & BackUp1

    Edit: Also now tried cleaning cache
  2. tomf87 macrumors 65816


    Sep 10, 2003
    You may have already tried this, but have you renamed the hard disk back to what it was? It really shouldn't matter if this is the boot drive, since it is mounted as /, but if it is a secondary drive, it is mounted under /Volumes so changing the name changes the Unix path to it.
  3. madamimadam thread starter macrumors 65816


    Jan 3, 2002
    You started me on the right track, thanks heaps

    Had to change the name of the server to just LDAP. I imagine it was having problems with either the "&" or the spaces. I don't feel like playing around to find out which, though.

    I have to reset up the users and copy over their home folders but better than reinstalling everything.

Share This Page