iPhone REF: Straight Talk Data settings for iPhone (in case anyone needs)

Discussion in 'Jailbreaks and iOS Hacks' started by jnl1211, Jul 18, 2011.

  1. macrumors 6502

    jnl1211

    Joined:
    Jan 29, 2011
    Location:
    NWIndiana
    #1
    So these aren't always easy to find so in case anyone needs them here are my (working) data settings for using Straight Talk on an iPhone:

    You'll need TetherMe or an APN Editor from Cydia (If you use tetherMe turn off Auto APN in settings)
    Navigate to Settings - General - Network - Network settings

    Cellular Data:
    APN: att.mvno
    Username: (leave blank)
    Password: (leave blank)

    Visual Voice Mail: (Does not work so it can say whatever)

    MMS:
    APN: att.mvno
    Username: (leave blank)
    Password: (leave blank)
    MMSC:http://www.mmsc.cingular.com
    MMS Proxy: proxy.mvno.tracfone.com:80
    MMS Max Message Size: 1048576
    MMS UA Prof URL: (leave blank)

    Restart if you'd like or toggle airplane mode, there you go. Working Data/MMS on your iphone with Straight Talk.
    _____________________________________________________________

    -- ALTERNATIVE -- On 4.3.3 and below
    Download and unzip attached .ipcc file
    Open Cydia. Add the repo: http://cydia.d23.com.uy/
    Install Comm Center Patch.
    Restart phone
    Connect to and open iTunes
    Hold shift and click "Check for update"
    Browse to unzipped ipcc and select it
    iTunes will update your carrier settings. Banner and Carrier in "About" section in settings should say "Straight Talk" and data settings will be set correctly
     

    Attached Files:

  2. macrumors newbie

    Joined:
    Nov 4, 2011
    #2
    Set everything and I can receive but can not sent any suggestion?? On 3GS with 4.3.3 firmware
     
  3. macrumors newbie

    Joined:
    Feb 17, 2012
    #3
    didnt work

    The itunes would not upload that folder

     
  4. macrumors newbie

    Joined:
    Feb 20, 2012
    #4
    I've jailbroken, installed TetherMe and changed the APN with the exact information you posted, but my iPhone 4 still will NOT work for MMS. Help? :(
     
  5. thread starter macrumors 6502

    jnl1211

    Joined:
    Jan 29, 2011
    Location:
    NWIndiana
    #5
    Make sure TetherMe isn't set to Automatic. Sometimes if it's set to automatic it'll change the att.mvno on the MMS APN
     
  6. macrumors newbie

    Joined:
    Jul 26, 2011
    #6
    somewhat working

    I have an iPhone 4 and have been trying to get picture messaging working. I have been able to finally get the internet working. But it still fails to send pictures to non iPhone users. I can send text messages and get on the internet. Does anyone have any additional input on getting iphones to work correctly on straight talk? My settings are as follows under mms tab:
    APN: att.mnvo
    UN: blank
    PW: blank
    MMSC: http://mmsc.cingular.com:80
    MMS PROXY: proxy.mnvo.tracfhone.com:80
    MMS Max Message Size:1048576

    This is what the current settings are in my phone, but picture messages still fail. Here are settings that straight talk has provided me to input into the phone, but.....the mms proxy is different and a few other things are different. Does anyone have any ideas on the right info on what i need to change to make pic messages work?
    Straight Talk information supposed to be in phone:
    Name: Straight Talk
    APN: att.mnvo
    Proxy: proxy.mnvo.tracfone.com
    Port:80
    MMSC: http://mmsc.cingular.com
    MMS Proxy: 66.209.11.33
    MMS Port: 80
    Thanks again.
     
  7. macrumors 6502

    Joined:
    Jan 30, 2010
    #7
    Your current settings should be fine, but you spelled "tracfone" wrong in the MMS Proxy field.
     
  8. macrumors newbie

    Joined:
    Jul 26, 2011
    #8
    Sorry, the mispelled tracfone was just a typo in my typing on the post here. It is spelled correctly on the phone. And it still will not send a picture message. It loads the picture on the phone, ans starts to send, the bar goes across the screen through the sending process, then it fails. Sometimes it almost gets finished, others it might get 25%. Any other ideas whats going on? Has anybody on the new straight talk sim with iphone 4 been able to send picture messages to another phone besides an iphone?
    thanks again.
     
  9. macrumors 6502

    Joined:
    Jan 30, 2010
    #9
    It's been working fine for me with an iPhone 4S.

    Have you tried testing it with the other settings you posted previously?
     
  10. macrumors newbie

    Joined:
    Jul 26, 2011
    #10
    What are your settings? What part do I need to change and to what?
     
  11. macrumors 6502

    Joined:
    Jan 30, 2010
    #11
  12. macrumors regular

    xpected_one

    Joined:
    Sep 23, 2008
    Location:
    Texas
    #12
    I have tried everything to get mms working and still no luck .... Weird part is to get my data working I had to leave all the fields in that section of apn settings blank. Any ideas ????
     
  13. macrumors newbie

    Joined:
    Jul 26, 2011
    #13
    I still haven't figured mine out yet. I have entered all the ones i have found. I wish i could find someone that had the straight talk and an iphone and everything worked for them. Maybe we will find someone sometime as time goes on and more people switch. Maybe more people will have the problems and get it figured out sometime.
     
  14. macrumors regular

    xpected_one

    Joined:
    Sep 23, 2008
    Location:
    Texas
    #14
    Ya that's my hope as well... Although it does seem like there are people with ST and iPhones that have everything working. I have noticed that most of those are people that bought a E71 and used that sim card. I actually bought mine from ST and ported my AT&T number over. Maybe that might have something to do with it?
     
  15. macrumors newbie

    Joined:
    Jul 26, 2011
    #15
    I have the straight talk sim card program also. I think a lot of the settings that i am finding are coming from the nokia sims and not the real straight talk sims. I need the settings for the real straight talk sim from the bring your own phone program, as do you.
     
  16. macrumors regular

    xpected_one

    Joined:
    Sep 23, 2008
    Location:
    Texas
    #16
    I will keep browsing, if I make any head way Ill post back here!
     
  17. macrumors 6502

    Joined:
    Jan 30, 2010
    #17
    I purchased the ST MicroSIM from their BYOD website. No E71, no other phones. Put it into the iPhone, activated on their website, manually edited the APN settings using the instructions from this website, and everything has worked.

    I am using an iPhone 4S that is unlocked. I doubt that makes a difference, though.

    Just to confirm, you are using the AT&T, and NOT the T-Mobile SIM, correct?
     
  18. macrumors regular

    xpected_one

    Joined:
    Sep 23, 2008
    Location:
    Texas
    #18
    That is what I ordered from straighttalk.. Is there maybe a way to tell the difference ? I assumed that they sent me the correct (AT&T gsm) sim when I placed the ordered but I guess anything is possible.
     
  19. macrumors newbie

    Joined:
    Mar 9, 2012
    #19
    I also have an iphone 4 and am using straight talk sim with the settings provided here with no luck. Anyone try the settings provided with the straighttalk sim card package?
     
  20. macrumors regular

    Sulten

    Joined:
    Oct 24, 2011
    #20
    saw this video has anyone tried this? to see if it works

    hxxp://youtu.be/Y9wU8J24RA4
     
  21. macrumors newbie

    Joined:
    Mar 9, 2012
    #21
    Guys, I fixed my issue last night. This is what worked for me. On the "MMSC:http://www.mmsc.cingular.com" I took out the "www" part. So it looks like this instead "MMSC:http://mmsc.cingular.com". Without the ", of course. Also, instead of "proxy.mnvo.tracfhone.com:80" I used the numerical name instead which is,MMS Proxy:66.209.11.33:80

    So it should look like this.

    MMSC:http://mmsc.cingular.com
    MMS Proxy:66.209.11.33:80

    the rest of the settings like everyone has been posting.
     
  22. macrumors newbie

    Joined:
    Mar 16, 2012
    #22
    None of these settings are working for me. I have just wasted the last 14 hours and $5 on tetherme.

    When someone figures this stupid thing out, would you please let me know. I'm ready to chunk my laptop and the iphone out the window.
     
  23. macrumors newbie

    Joined:
    Mar 18, 2012
    #23
    Surprised by CS and it works!

    Ok, si i tried all these options and they all failed. Still no MMS or data:

    1. used apn settings on the activation card
    2. Used apn profile from unlockit
    3. used custom apn profile from another site

    I was ready to quit.
    I then decided to call customer service and see if they could help me. I figured it would be a long wait given my experiences(H2O wireless) i hunkered down with a cool drink and my bluetooth on and prepared to waist at least an hour of my life. I was speaking to a customer service rep within 2 minutes of dialing. I told them i had no mms or data on an iphone 3g. They said i would have to be transferred over to someone else. I figured this is where the wait time would come in. It took less than a minute.
    The gentleman said the problem was on their end and he would fix it. Told me to restart the phone and call back if it didnt work. IT WORKED!

    Sinfonian's setting are correct. The problem lies at Straight talk and it takes less than ten minutes to fix

    ----------

    Call Straight talk, the problem is on their end. it takes less than ten minutes to fix!
     
  24. macrumors newbie

    Joined:
    Sep 14, 2012
    #24
    i have an i phone 3gs and its on straight talk and i have everything working talk text web mms no problems at all

    ----------

    heres how everything looks on mine
    APN att.mvno
    Username blank
    Password blank
    Visual voicemail
    APN acds.voicemail
    Username blank
    Password blank
    MMS
    APN att.mvno
    Username blank
    Password blank
    MMSC http://mmsc.cingular.com
    MMS Proxy 66.209.11.33
    MMS Max Message size 1048567
    MMS UA Prof URL
    everything works fine

    ----------

    i went into cydia and downloaded the tetherme app and it fixed everything cause i had the same problem hope this helps

    ----------

    thats what i posted scroll down and check it out
     
  25. macrumors newbie

    Joined:
    Mar 3, 2013
    #25
    I diasgree with most of these instructions. I have an iphone 4s working FLAWLESSY 100% the same as i did on att.


    Settings
    Cellular Data
    APN: att.mvno
    Username:
    Password:
    MMS
    APN: att.mvno
    Username:
    Password:
    MMSC: http://mmsc.cingular.com
    MMS Proxy: 66.209.11.33:80
    MMS Max Size: 1048576
    MMS UA Prof URL:

    NOTHINH more and nothing less. It will work PERFECRt (if you can figure out the little tricks to getting th sim swap to work.

    DO NOT put straight talk or trac phone proxy! PERIOD, you do not want them trottling or watching you! SO instead of going to their servers you go straight to att MVNO servers..

    Trust me it works
     

Share This Page