1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

rEFIt And Lion Do Not Work Together // Could It Be FileVault??

Discussion in 'Mac OS X Lion (10.7)' started by rmbrown09, May 10, 2011.

  1. macrumors 6502a


    Have FileVault enabled, 10.7 latest build installed.

    Installed rEFIt, just as the readme and site describe, however the altered boot menu does not appear when starting up.

    Is this a 10.7 thing or a filevault issue.. anyone without filevault on try this?

  2. macrumors regular

    Hate to drag up a 30+ day thread however, I too can not get reFit working w/ OSX Lion (DP4).
  3. macrumors 6502a


    Good news is I figured out the problem a while back. Boot from a lion installer via a disk or USB and repair the disk. Should come up after that.
  4. macrumors regular

    What version are you using I am on dp4 and that did not work. Trying to remove refit 100% now
  5. macrumors 6502a


    Well I was on DP3 at the time. Now DP4, still works from when I repaired it back then. Are you sure you repaired the disk and not the permissions?
  6. macrumors regular

    I tried both and it did not work. I just reinstalled DP4 again going to try repairing permissions first.
  7. macrumors 6502a


    Lion DP4, and previous DPs, work fine with refit for me. I don't use VileFault.
  8. macrumors regular

    Disk repair did not resolve it, after doing that osx did not accept my password and would still not show refit. I also noticed that every other reboot I had to force it off. It seems to me it was hanging at the point it would normally load rEFiT. I am guessing it is some issue with refitblesser.
  9. macrumors 6502a


    Uninstall and re install Refit I guess.
    Actually on my Air is doesn't always always pop up when I start. Like 1 / 5 will just skip the Refit screen and go to boot.
  10. macrumors newbie

    How to boot into OSX Lion 10.7 with rEFIt

    Hello folks. I have read many if not all the posts on the subject of how to boot into OSX Lion 10.7 with rEFIt, and while they seem to indicate that it is posible, no one seems to have a definitive method on how to achieve it consistently.

    I recently bought a 15" MBP 2.3ghz machine. I replaced the 500gb HDD with a 120gb Vertex 3 SSD, partitioned for Windows and OSX. I replaced the Optical drive with a 7200 rpm 750gb HDD (for data) and upgraded the ram to 8gb.

    Here is what I did after my initial failures to boot into Lion with rEFIt. (rEFIt was already installed in Lion and Snow Leopard.)

    I attached the original 5400 rpm, 500gb Snow Leopard HDD via usb cable to the MBP. I booted into Lion and selected the external Snow Leopard HDD as my startup disk, in System Preferences. On the first reboot into Snow Leopard rEFIt came up. I selected Lion, and logged in. I restarted the MBP. On the second reboot, rEFIt came up again. I chose Lion, and while the machine was booting into Lion, I disconnected the Snow Leopard HDD. When I rebooted the MBP with just Windows 7 and Lion, rEFIt still came up.

    I hope this helps.

    Now what I would like to know is if anyone has had any success with running Roboform on Lion. I was able to get it to work on Snow Leopard 10.6.7 after a shaky start.

    All help would be appreciated.
  11. macrumors 6502a


    I have been using rEFIt for a while and if you have FileVault on in Lion it is definitely to blame for rEFIt not working.

    I decided to try FileVault on Lion last night and after all was setup and encrypted, I rebooted only to have rEFIt not load and Lion automatically boot. Obviously this has to do with FileVault now encrypting the entire disk and not just the home folder in Lion. Snow Leopard also can't recognize the Lion partition anymore in Disk Utility.

    The only way I could get rEFIt to load after activating FileVault in Lion was to hold down Option at boot and select rEFIt to boot from. After selecting it, the rEFIt boot selection screen would show up, but no option to boot from Lion was there.

    I didn't have any of these problems with rEFIt until I turned on FileVault. It would always show up at boot and would let me select either Lion or Snow Leopard to boot from.
  12. macrumors newbie


    Thanks for all the feedback everyone. Quick question. Currently running on my MBA 13 Windows 7 and OSX Snow Leopard. This was installed using Refit EFI as I do not have an external drive, I used a USB stick for Windows 7. If I go to App Store and download Lion and upgrade, will this stop my Windows 7 partitiion? Delete it?

    If it just stops it, can I fix it? ... What are the steps to get it to work if it won't? OR will it work just fine?

    Last but not least, if I upgrade to the new refit version, will it fix this problem?

  13. macrumors 6502a


    To get Refit to work properly I had to manually install the package. The installer package did not work.

    It's just a 2 line terminal command that goes like this. Try this after you try the installer package. or if it's already in place. (which it should be since you have it installed now)

    cd /efi/refit
  14. macrumors newbie


    So to confirm - I will not loose access to my partition in bootcamp?
  15. macrumors 6502a


    If you do an upgrade then no you will not lose the partition... If you clean install then you will.

    Either way do this, It's called WinClone and it makes an image of your bootcamp partition.


    Make an image and store it somewhere else. Then you can restore that image with the same program should something go wrong.
  16. macrumors newbie


    Thanks guess I am just concerned with the EFI boot BS cause I didnt do a traditional install. I read that the file vault will lock out the partition etc?
  17. macrumors 6502a


    Turn FV off just in case.
  18. macrumors newbie


    Why cant we just move the Office products from PC to MAC UGGH! the same versions!

  19. macrumors 6502a


    do you not have office for the Mac side?
  20. macrumors member

    just got through my Lion upgrade and thought I'd throw in my 2 cents...

    after purchasing on the AppStore [on our family iMac], I copied the 4GB installer to an external using these instructions - I added .app to the root folder to be able to double-click it.

    i plugged it into my MacBook which is a triple-boot using rEFIt and the first warning is it couldn't create the Recovery Partition so I hit continue. it rebooted and notice rEFIt didn't kick in so that's how I got to this thread. the install didn't proceed and realized I didn't apply the necessary patches (10.6.8) so I applied them.

    when my mac rebooted after the 10.6.8 upgrade, rEFIt kicked in (whew) and when I double-clicked on the Lion installer on my Firewire drive - it gave me that [Recovery] warning, clicked "Continue" and everything upgraded like a charm.

    on reboot, I have my triple-boot MacBook back again with Lion under the helm :)
  21. FireSokar, Jul 22, 2011
    Last edited: Jul 24, 2011

    macrumors regular

    Glad to see you have refit working, I am still one of the few people stuck with refit never working properly on Lion. It worked perfectly on Snow Leopard but now everytime I install the mpkg it just does not kick in and refitblesser seems to never run properly.

    Edit: I have finally gotten reFIT to work on my MacBook Pro 2011 15 in. I had to manually install it. Upon booting into windows I discovered that reFiT is the reason my audio controls did not work in snow leopard. A quick google check and others have also figured this out recently as well.
  22. macrumors newbie

    I have the same problem as urs. Could you please tell me (in details) how did you manage to solve it ??? after updating to Lion ,Refit is not working anymore and laptop hangs on reboot.
  23. macrumors member


    Same problem here. Is there a simple straightforward solution to this?
  24. macrumors regular

    You will need to boot into OSX and install reFiT manually. open a terminal and navigate to the EFI directory. Run the enable sh file using sudo. There are specific instructions on the refit website for a manual install. This works until a new update is out, you may also want to remove refitblesser from your start-up items folder first. This will make the brightness controls under windows wonky since the 2011 MBP has issues with refit.
  25. macrumors newbie

    Solution to refit hanging startup of os x

    Had major frustrations with my Mac after installing refit.

    After trawling through countless forums and endless suggests I found one that was simple and fixed my problem. Although meant that I had to delete refit (which I was happy to do).

    Solution to hanging startup: delete refit blessed from startup items.

    After I did this the Mac started like a charm every time!

    Hope this helps.

Share This Page