Resolved Remove Computer from WiFi Sync

Discussion in 'iOS 5 and earlier' started by Jony Mac, Jan 16, 2012.

  1. Jony Mac, Jan 16, 2012
    Last edited: Jan 17, 2012

    macrumors 6502

    Jony Mac

    Joined:
    Oct 27, 2010
    Location:
    Pittsburgh, PA
    #1
    I synch my iPhone/iPad with my Mac at home either on Wifi or tethered. Today I plugged my iPhone into my work machine while playing music. I have the options set in iTunes to not sync automatically, however now I see on my iPhone under the Wifi Sync menu that both computer names show up.

    The first is my home machine
    The second is my work machine.

    Is there a way to remove computers from Wifi Sync in iOS 5?
     
  2. macrumors demi-god

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Plug into computer you don't want and uncheck wifi sync
     
  3. thread starter macrumors 6502

    Jony Mac

    Joined:
    Oct 27, 2010
    Location:
    Pittsburgh, PA
    #3
    The thing is, its already un checked.I guess i could wipe the phone, but thats really a pain in the butt
     
  4. macrumors 6502a

    Macsterguy

    Joined:
    Jun 5, 2007
    Location:
    Texas
    #4
    Same issue and I have been working with apple engineers since November.
     
  5. macrumors regular

    sulliweb

    Joined:
    Mar 13, 2011
    #5
    I don't think they have a very good handle on this whole WiFi sync thing... I wish they waited until they actually knew what they were doing before the introduced it...
     
  6. Jony Mac, Jan 16, 2012
    Last edited: Jan 17, 2012

    thread starter macrumors 6502

    Jony Mac

    Joined:
    Oct 27, 2010
    Location:
    Pittsburgh, PA
    #6
    Resolved

    I got this fixed. Here is what I did. I went into
    • Settings
    • General
    • Reset
    • Reset All Settings

    Let the phone reboot, connected to my wireless here to activate my device. Doing this kept all of my data, apps, mail, etc on the device. Now I have the option to plug the iPhone into a computer to perform Wireless Sync. Sure it was silly to remove all settings, but now I got rid of the extra PC it wanted to sync with, and I didnt have to wipe the device.
     
  7. macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #7
    Sorry to resurrect an old thread but I have the same issue. I just bought the phone jailbroken and unlocked a few days ago. All is well and it syncs fine with my computer, but when I look on the iPhone it lists 2 other computers besides mine that I have no access to, and it just seems weird to see somebody else's computers listed. Is the 'Reset All Settings' above safe for jailbroken/unlocked iPhones (I don't think so). I can't believe that Apple has no other way to remove these unwanted computers from the wifi sync list.
     
  8. macrumors 6502

    KittyKatta

    Joined:
    Feb 24, 2011
    Location:
    SoCal
    #8
    I got a new Air and want my iOS devices to stop WiFi syncing to the old Mini. Ive followed all the advice found online and in the end they keep going back to their old "Master" instead of syncing to the new one.

    This didn't work. Wireless sync did say that I need to connect to a computer in order to establish a WiFi sync but when you do then it says "Mac Mini" again so the setting reset did nothing.

    When you reconnect to the new computer and recheck "WiFi" then it re-establishes its old link to the old computer.

    Ive got 4 iOS devices doing the exact same thing. No, this isn't a "Prevent iPhone from syncing to this computer" type of simple solution. This is something more complex where the devices need to forget the old computer completely so if anyone has advice on what else to try then I'd appreciate it.
     
  9. MOD.and.OP, Dec 7, 2014
    Last edited: Dec 7, 2014

    macrumors newbie

    Joined:
    Jul 15, 2010
    #9
    I have a jailbroken phone. I was looking for a way to fix this that did not include resetting (those of us with jailbreaks cannot reset, we lose them) so I figured it out. I was able to delete the old entries and start fresh and resync. Navigate to and delete the old entries in:

    Code:
    /var/mobile/Library/Preferences/com.apple.atc.plist
    OR you can Backup the file (just in case) and delete it. I know this thread is really old, but it popped up when I did a search for this problem, and I hadn't seen the solution posted anywhere else. After I did everything just magically started working properly.
     

Share This Page