Removing ATV4Windows

Discussion in 'Apple TV and Home Theater' started by gtg941f, Jun 29, 2008.

  1. macrumors newbie

    Joined:
    Jun 29, 2008
    #1
    I tried patching with ATV4Windows 2.4 and everything appeared to be going well, except on the final reboot (after patching with the minute countdown), it rebooted to the normal ATV home screen with no changes.

    Now, everytime I reboot and try to use another patchstick, the modified boot sequence won't allow the patchstick to run.

    Soooo, my actual request: does anybody know how to restore all the files to exactly as the ATV was purchased (2.02)? I want to get back to the factory defaults and all original files without the modified ATV4Windows boot so that I can attempt to use another Patchstick.

    Thanks
     
  2. macrumors 6502a

    Joined:
    May 15, 2007
    #2
    AppleTV main menu:
    Settings -> General -> Reset Settings -> Factory Restore -> Restore
     
  3. thread starter macrumors newbie

    Joined:
    Jun 29, 2008
    #3
    I certainly wish that would work. However, when using that method it restarts but still shows the atv4windows splash screen before the apple, and then just like the initial patching it goes to the "atv4windows initializing/patching..." screen, restarts and shows the normal unmodified atv home.

    Basically if I restart/restore/yank the cord out and restart that way, it always reverts back to that dang "atv4windows initializing/patching..." screen like it should have done once successfully. Seems like an absolutely remote issue that couldn't have been predicted.
     
  4. Gee
    macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #4
    If you've got your appletv on a wireless network, it gets stuck like this I think. Did you try it with a wired connection? The patching process downloads some files, and if it can't find them, it can't finish.
     
  5. macrumors newbie

    Joined:
    Jun 30, 2008
    #5
    I have exactly the same problem. Any help would be appreciated.
     
  6. thread starter macrumors newbie

    Joined:
    Jun 29, 2008
    #6
    Just so that everybody is aware, it appears the two developers of atv4windows split ways and the person who is now doing atv patch (cisco) appears to have distribute a bum patchstick which deletes your recovery drive on the ATV.

    To recover the entire drive, there is now a recovery patchstick so you don't have to follow those really long instructions. http://www.atvmod.com/forum/viewthread.php?forum_id=5&thread_id=8

    That site is from one of the developers. He basically took everything and left Cisco (good!). So ATV Mod is essentially ATV4W 2.5 and it's distributed for free on his site!
     
  7. macrumors newbie

    Joined:
    Jun 30, 2008
    #7
    Did you manage to get the patch. The site is currently closed?:(
     
  8. macrumors 6502

    Joined:
    Jan 10, 2007
  9. macrumors 6502a

    Joined:
    May 15, 2007
    #9
  10. macrumors 6502

    Joined:
    Jan 10, 2007
    #10
    Geeesh, if your ATV is already so screwed up it's not booting what's not to hurt trying something?

    I got the links from the atvmod.com forum site. Join up and see what people are saying about this patch helping them out when all things looked pretty bleak. I'm neither promoting nor condoning this patch, just merely passing on some hopefully useful info. In fact here's a couple of posts from the thread:
    -----------
    Posted on 30-06-2008 00:14
    Fn AWESOME!!! monty432 thanks so much. My ATV is back to "normal"..ver 2.02... soon to get the "proper" upgrade. Not even a day went by from the time i made the request till a solution from the forum, thats great. Thanks to everyone that offered help. Obviously this forum / site is the place to go for ATV.

    Thanks again...

    ----------
    Posted on 30-06-2008 11:35
    Yip thanks monty432. You've saved my bacon with the restore patchstick!!!

    We're not worthy.

    ----------
    Hey monty432....uuuuuuuuuuuuuuuuuuuuuuuuuu the mannnnnnnnnnnnnnnnnn!

    Patchstick recovery...how sweet. Thank you members of atvmod.com.

    Wanted to add that the patchstick worked perfectly for me. Completely got rid of that BrickTv crap.
     
  11. macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #11
    I knew we should have ordered that patchstick from you.
     
  12. macrumors 6502

    Joined:
    Jan 10, 2007
    #12
    And have you seen the YouTube video of the guy doing a sales job on how his patch works? Slimy and creepy and majorly unprofessional!
     
  13. macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #13
    Are you referring to "tom" when you say "the guy?" I'd be interested to know. And I forgot to include the appropriate :rolleyes: in my last post. Sorry.
     
  14. macrumors 6502

    Joined:
    Jan 10, 2007
    #14
    Nope -- CiscoTM. I thought you were cynically referencing Cisco.
     
  15. macrumors 6502a

    Joined:
    May 15, 2007
    #15
    "Never argue with an idiot... for they will drag you down to their level and beat you with experience"

    A nice quote that I found in someones signature on this forum.

    All said and done.
     
  16. macrumors newbie

    Joined:
    Jun 30, 2008
    #16
    Hi all,

    I just tried this and it doesn't appear to work (assuming I have done everything correcty). It loads up to the point of getting the following message :Cannot unmount/mnt/OSBoot: No such file or directory.

    If anyone else has tried this, can they please provide some feedback. I have assumed that I make the patchstick the same way v2.4. I noted an extra file in the download recovery-fix.img.md5. which I didn't use.

    Any help would be appreciated.
     
  17. macrumors newbie

    Joined:
    Jun 30, 2008
    #17
    Me again,

    Was contacted by atvmod re my problem. Went back and tried restoring factory settings for a 3rd time and guess what, it worked!!!

    There some sort of magic happening at atvmod.:D

    Thanks everyone for helping get this resolved.
     
  18. thread starter macrumors newbie

    Joined:
    Jun 29, 2008
    #18
    The links above do in fact work. They restored my recovery partition and allowed me to factory restore and start all over.

    Thanks to the folks over at atvmod who are working to clean up this mess that the slimeball Cisco created.
     
  19. macrumors newbie

    Joined:
    Apr 8, 2008
    #19
    just so you know, i did nothing to this file, the code was injected threw the internet, this is y we removed it from our website, but some one leaked it onto bit torrent and now it can not be stopped.!
     
  20. macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #20
    What he originally posted.
     

Share This Page