Repairing Permissions and ARDAgent

Discussion in 'OS X' started by zign, Oct 26, 2007.

  1. macrumors 6502

    zign

    Joined:
    Apr 9, 2006
    Location:
    London
    #1
    I am getting this when repairing permissions : "Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired."

    Doesn't look like permissions get fixed.

    What can I do?
     
  2. macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #2
    You're not the only one to report this - SINC on ehMac.ca reports the same thing.

    ARDAgent is part of Apple Remote Desktop.

    First: turn off Apple Remote Desktop in your System Preferences and try Repairing Permissions again.

    Can you find and delete that file/package? Presumably it can be reinstalled with a custom Install later.
     
  3. macrumors newbie

    Joined:
    Oct 27, 2007
    Location:
    Ames, IA
    #3
    Same problem here. Tried it several times and always the same error message. I tried restarting and running disk utility from the Leopard Installation Dvd, same error. And Permission Repair (or Verify) takes a lot more time than it did with Tiger. It doesn't show a progress bar either. Just the blue/white spinning bar (I don't know what it's called). I called Apple Customer Support but they couldn't help. Told me to backup my data and Erase/Install Mac OS again!! (I'm not doing that!)

    I was thinking it was a problem with my system, but now that I see I'm not the only one experiencing this, I guess it's a Disk Utility bug. Hope Apple fixes this soon.
     
  4. macrumors newbie

    Joined:
    Aug 21, 2006
    #4
    Same problem for me, but it showed up only after update
    Update was something about remote....

    but im getting two more problems

    ACL found but not expected on "Applications".
    ACL found but not expected on "Library".
     
  5. macrumors member

    Joined:
    Dec 16, 2004
    Location:
    Detroit
    #5
    Same here. Always see those three. And it really takes time to repair or verify.
     
  6. macrumors 6502

    Joined:
    Oct 26, 2007
    #6
    I've had this problem each time and on three different installs. It was there when I did a 10.4.10 to 10.5 upgrade. Long time to repair permissions and then gives that error. Then I did a clean install of just 10.5. Still there. Finally I did a clean restore to 10.4 and updated through software update to 10.4.10. Then I upgraded. The problem is still there.

    It seems to be an issue with Disk Utility. When I boot up from the install disc and try to repair the HD/Repair Permissions it says the disc won't unmount. Says the same thing for my external Firewire 400 HD. When I do verify HD under the repair option for my external the whole computer locks up.

    Apple really needs to address this problem and fix it ASAP before too many important people lose all their files as some already have over this.
     
  7. macrumors member

    Joined:
    May 8, 2002
    Location:
    Australia
    #7
    I'm getting the same issue. Can you tell me if you are having problems with setting permissions? When I do a get info on a folder or file there is "me" "unknown" and "everyone" I don't know what the unknown is and I can't delete it. If I click on the + symbol it crashes the Finder also. It seems that the permission setting do not work at all. The lock icon does not always animate also.
     
  8. macrumors 6502

    Joined:
    Aug 12, 2007
    Location:
    Hollywood, California
    #8
    i can remove unknown. but, it had me on there twice.

    permissions is acting weird though. my fiancee is on a vista machine (not for too much longer), and her pc just comes and goes in network view in finder. it's there one minute gone the next... may be a vista issue though.
     
  9. macrumors newbie

    Joined:
    Aug 21, 2006
    #9
    i got rid of "Warning: SUID file... simply just by moving file System/Library/CoreServices/RemoteManagement/ARDAgent.app to other directory
     
  10. macrumors 68000

    russed

    Joined:
    Jan 16, 2004
    Location:
    London, England
    #10
    i'm just having problems with the long time that it takes to repair permissions. It has been going for a long time now and it is still 'starting to verify'.

    I really think they all need updating as there are quite a few flaky elements occurring. Does anyone know how to solve this without doing a clean install? I upgraded from 10.4.
     
  11. macrumors 6502

    appie57

    Joined:
    Oct 27, 2006
    Location:
    Netherlands
    #11
    Same problem here

    on both our MBP's got the SUID... warning when verifying permissions. Waiting for a solution...
     
  12. macrumors 6502

    Joined:
    May 28, 2006
    Location:
    MN
    #12
    I'm having the same issue with a clean install on a CD Macbook. Mine also continues to show 'starting to verify' until i get a operation timed out error.
     
  13. macrumors member

    Joined:
    May 8, 2002
    Location:
    Australia
    #13
    How long are you guys talking about? My repair permissions hangs for about say 5-7 mins then completes its assumption in a couple of seconds.
     
  14. macrumors 6502

    Joined:
    May 28, 2006
    Location:
    MN
    #14
    Just retried it and got the ARD issues as posted above. Not going to bother with it until again until we see some an update.
     
  15. macrumors newbie

    Joined:
    Jan 25, 2004
  16. macrumors 68000

    russed

    Joined:
    Jan 16, 2004
    Location:
    London, England
    #16
    well i left it going, went away from my computer after sitting waiting for about 10 mins, then about 20 mins later it had finished without doing anything.

    its so annoying as things are pretty flaky, restarts are very slow along with most other things.

    I have tried both disk utility and system optimizer x - both do the same thing.
     
  17. macrumors newbie

    Joined:
    Oct 26, 2007
    #17
    Spoke with apple for 3 hours

    After being on the phone with apple for 3 hours trying to fix"System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired."
    They had me boot off the disk and safe mode. They moved me to a product specialist and we worked with a few different thing. He sent it on to the engineers and he wants me to call him back on Tuesday.
    Other than this everything is running good. Disk permission is slow but it completes with in 10 min.
     
  18. macrumors regular

    Joined:
    Aug 22, 2005
    #18
    Exactly the same issues here. Slow repairing of permission and then the odd problems as discussed earlier with ARDAgent and the two folders.
     
  19. macrumors 6502

    Joined:
    Jul 18, 2002
    Location:
    Local
    #19
    Same here:

    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.

    and

    ACL found but not expected on "Library".

    Hope they come up with a fix soon. I wasted three hours doing an erase and install and manually copying everything to fix this, all to no avail. Glad I'm not alone.
     
  20. macrumors 6502

    Joined:
    Jan 6, 2004
    Location:
    Sheffield, UK
    #20
    Same here

    Repairing permissions for “Mac Pro”
    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.
    ACL found but not expected on "Library".

    when repairing permission, the disk utility seems to 'hung' / beachball for about 3 to 4 minutes....

    this problem only occur in Leopard.



    Also, the computer keeps forgetting the startup disk hence the flashing folder with question mark.

    Are these 2 problems related?
     
  21. macrumors 6502

    Joined:
    Jul 18, 2002
    Location:
    Local
    #21
    Zoowatch, I don't have the startup disk problem, so maybe it's caused by something else. I did get one problem of not being able to log in at all on any disk (this was after installing the log in patch), eventually solved it by shutting off the bluetooth keyboard and mouse. Go figure. They work fine now. Seems like they released Leopard a little early.
     
  22. macrumors regular

    sulhaq

    Joined:
    Jul 29, 2006
    #22
    Same here. Ever since I installed leopard on my MBP 2.33g 3gig I'd been getting the following error:

    ACL found but not expected on "Applications".
    ACL found but not expected on "Library".

    Ever since I did the Remote Desktop Management update I started getting the "SUID ARDAgent" error as well. Now, whenever I repair permissions it takes forever to finish, repairs nothing and gives me the above three errors.
     
  23. macrumors newbie

    Joined:
    Oct 30, 2007
    #23
    Warning: SUID file has been modified and will not be repaired

    If you have no intention to use the remote desktop application, then delete the following folder, you can always re-install from the leopard start up disk.

    System/Library/CoreServices/RemoteManagement

    Fixes the issue;

    Warning: SUID file has been modified and will not be repaired

    If you need the remote desktop app, tough, wait for Apple to admit there is an issue and hide it in one of the next software updates, hope your system doesn't become too unstable in the interim.

    I have deleted it and the disk utility come up with a satisfying clean bill of health.

    Not big, not clever, but it works

    Thanks


    Billyb
     
  24. macrumors 6502

    Joined:
    Sep 18, 2007
    Location:
    Vancouver, BC
    #24
    This has been posted on the Apple Discussion Forums by quite a few people, so its obviously a common problem, and I assume the next updates will fix it. I have it too.
     
  25. macrumors newbie

    Joined:
    Oct 30, 2007
    #25
    Disk permission repair

    unfortunately the issue is more serious than it seems. Aside from the error message: System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.

    Leopard does actually not repair any disc permissions, that's why there is no moving progress bar and thats why nobody gets a list of repaired permissions. The utility does eventually give the message that permissions have been repaired, but in reality nothing has happened.

    Even after removing the ARD agent application, yes the error message disappears but no permissions are being repaired and after the progress bar flashes for up to 20 min (depending on your system), no progress is being made, no permissions are being repaired.

    This is a serious issue and hopefully Apple will post a fix soon.
     

Share This Page