[Repairing permissions] Something to worry about?

Discussion in 'macOS' started by LSS, Aug 18, 2005.

  1. LSS macrumors member

    Joined:
    Mar 18, 2005
    Location:
    in your world
    #1
    Is this normal?

    I have Tiger and all updates installed.
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    I declare it "Normal".

    Unless of course this happens EVERYTIME you repair permissions?
     
  3. LSS thread starter macrumors member

    Joined:
    Mar 18, 2005
    Location:
    in your world
    #3
    Well, actually, it does... almost.
     
  4. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #4
    Almost?

    Does the php stuff come up everytime?

    Do you run a webserver or do php work?
     
  5. LSS thread starter macrumors member

    Joined:
    Mar 18, 2005
    Location:
    in your world
    #5
    I just repaired permissions twice and got this both times:


    Nope.
     
  6. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #6
    Soooo.. what are the permissions on those files/directories then?

    ls -l /Library

    ls -l /usr/lib/php/build

    Personally, I wouldn't worry about the widget one, but the php one.. I don't know what that one is all about.
     
  7. LSS thread starter macrumors member

    Joined:
    Mar 18, 2005
    Location:
    in your world
    #7
    drwxr-xr-x 16 root admin 544 Mar 21 07:12 Widgets

    and

    -r--r--r-- 1 root wheel 50268 Jun 1 09:41 acinclude.m4

    I just googled for those "errors" and found out that I'm not the only one with these. The widget one is normal. The php one apparently came with 1.4.2, but I didn't find any reasons or fixes for it.

    Oh, thanks a lot for trying to help! :)
     
  8. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #8
    Looks to me like #2 is a dud as well.. the current permission are those that the BOM archive says it's "supposed" to have, so when it says they're wrong, it's incorrect. I wouldn't worry about that one either.
     

Share This Page