restart computer every time I connect ipod

Discussion in 'iPod' started by psywzrd, Feb 17, 2009.

  1. macrumors 68030

    Joined:
    Feb 6, 2008
    #1
    I'm having a problem with my 30GB 5G ipod. Every time I connect it to my MacBook running Leopard it tells me that I need to restart my computer. This is an ipod that I've been using for quite a while and I've never had this problem before (it just started happening within the last day). I should also mention that I have a 2G Touch and an iphone 3G and I'm not having this problem with either one of those devices. Any idea what could be causing this and how I can fix it?
     
  2. macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #2
    try a repair permissions. applications --> utilities --> disk utility --> repair permissions
     
  3. thread starter macrumors 68030

    Joined:
    Feb 6, 2008
    #3
    Just tried that - didn't help. Anything else?
     
  4. macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #4
    try resetting the ipod. hold down center + play button.
     
  5. macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #5
    does this ipod have this effect on other computers?
     
  6. thread starter macrumors 68030

    Joined:
    Feb 6, 2008
    #6
    I tried the hold down center and menu buttons several times - the ipod obviously reboots like it's supposed to but it still does the same thing when I connect it to my computer. As for other computers, I only have one Mac so that is the only computer I connect this ipod to.
     
  7. macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #7
    reading and searching on the apple help forums it seems like the unifying thread between people with your same problem has to do with photos, especially those saved from the internet. sound like you?
     
  8. macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #8
    i would try removing any photos and then try syncing.
     
  9. thread starter macrumors 68030

    Joined:
    Feb 6, 2008
    #9
    Doesn't sound like me at all actually. The only thing on that ipod is my music and a few videos - that's it. I don't use it for photos at all (I only use this specific ipod at the gym). I tried connecting it to one of my windows PCs to make sure it wasn't the ipod and it seemed to be fine (obviously it told me that I needed to format it to use it under Windows so I did that). I then tried connecting it to my Mac again and the same exact thing happened - that tells me it has to be a problem on my Mac rather than on my ipod. I just wish I could figure out what the heck it is. Apple wants me to reinstall the operating system (they called it an archive something or other), but I'm trying to avoid that if possible.
     
  10. macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #10
    sorry to hear that. it still might not be your ipod's fault, or your computer's fault. it still may just be some weird compatibility quirk.
     
  11. thread starter macrumors 68030

    Joined:
    Feb 6, 2008
    #11

    It's so odd because I've never had any problems with this ipod until now. Maybe it has something to do with a software update that I might have done on my computer within the last few days or so. I just can't remember if I did a software update recently.
     
  12. macrumors 6502a

    joelovesapple

    Joined:
    Sep 25, 2006
    Location:
    UK
    #12
    Is iTunes fully up to date, as well as the iPod software on the device itself? We are currently on 8.0.2 .
     
  13. thread starter macrumors 68030

    Joined:
    Feb 6, 2008
    #13

    Yup - everything is up to date. I know this is a weird one and I really appreciate all you guys trying to help me.
     
  14. macrumors 6502a

    joelovesapple

    Joined:
    Sep 25, 2006
    Location:
    UK
    #14
    Strange then - I think it's definitely the iPod causing you grief. Maybe if you had an extended warranty on it you could send it to Apple for a repair and if they send you a new one, it might get rid of the problem...

    Have you tried restarting the iPod when it is mounted, from within iTunes? This completely empties the iPod and you have to reinstall the software on it, and you will need to resync it. Give it a try though and see if you get anywhere with it. Otherwise try the above suggestions.

    Good luck. :)
     
  15. thread starter macrumors 68030

    Joined:
    Feb 6, 2008
    #15
    I'm pretty sure it's not the ipod. I did an archive and reinstall of my operating system today and I made sure to not apply any of the Mac OS X updates after I was done - sure enough I was able to sync my ipod just fine. I think there was something in the most recent update that caused a conflict between my MacBook and this particular ipod. Now the only problem is that I can't update the operating system if I want to be able to use this ipod.
     

Share This Page