Rev. D Powerbook G4 with ASCII screen problem, possibly graphics card?

Discussion in 'PowerPC Macs' started by Rampant.A.I., Oct 4, 2009.

  1. macrumors 6502a

    Joined:
    Sep 25, 2009
    #1
    This is my lemon PB G4 that the girlfriend has been using after her PC died:

    [​IMG]

    It was acting up like this for a while, but the problem eventually went away after being turned off and allowed to fully cool.

    The machine started having the problem full time tonight.

    This laptop has been in and out of Apple's repair department and Apple stores the entire time I've owned it. The HD has been wiped just recently as the Apple Store's way of "solving" the issues it was having, namely unexplained freezes and fan noise.

    It's also on it's 2nd HD after the first one died without warning.

    Any ideas what's causing this? Is it reasonably fixable?
     
  2. macrumors 68030

    fun173

    Joined:
    Mar 2, 2009
    #2
    if it is still under applecare bring it in, if not then try shooting an email to sjobs@apple.com and describe the situation to them and tell them all the problems that you have had with the laptop. This looks as if the graphics card is failing but if it goes away after cooling down you may want to re-apply thermal paste to the graphics card.
     
  3. thread starter macrumors 6502a

    Joined:
    Sep 25, 2009
    #3
    Oh it's way out of Applecare.

    Apple made sure to stall a replacement for a good 2 years with the "oh, well if you have another major failure, we'll replace it" rule.

    It was a lemon that should've been replaced a long time ago, and I'm just hoping my current MBP won't be anything like the kind of garbage I went through with my last Mac laptop.
     

Share This Page