Right Clicking with Mighty Mouse

Discussion in 'Mac Accessories' started by cbrain, Jan 29, 2007.

  1. cbrain macrumors 65816

    cbrain

    Joined:
    Dec 9, 2006
    Location:
    North-East, UK
    #1
    Hi.

    I have bought a trial of World of Warcraft, and to start my first quest, I have to right click on someone. When I try to click right with my mighty mouse, it just sends the left click signal.

    Any advice or do I need to use a different mouse?
     
  2. Roy Hobbs macrumors 68000

    Roy Hobbs

    Joined:
    Apr 29, 2005
    #2
    Go into System Preferences and the Mouse and Keyboard you can set the Right Click there
     
  3. Maynerd macrumors regular

    Joined:
    Jan 4, 2007
    #3
    This happens to me too. What I suggest is that you do two things.

    1. Hold the mouse so that you are using the upper portion of the mouse when you right click.

    2. When you hit the right mouse button hold it instead of just clicking it.

    That's the best advice I can give you. The right click works better when I do this.
     
  4. Maynerd macrumors regular

    Joined:
    Jan 4, 2007
    #4
    Oh yes you need to enable this too. :)
     
  5. SpookTheHamster macrumors 65816

    SpookTheHamster

    Joined:
    Nov 7, 2004
    Location:
    London
    #5
    Make sure you don't have a finger touching the left side of the mouse when you right click.
     
  6. oceanmonster macrumors regular

    Joined:
    Jan 15, 2007
    #6
    enable it first in the system prefs. The to easily right click use your ring finger to click just above the right squeeze buton.
     
  7. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #7
    I was just going to say lift your left click finger. ;)
     
  8. Speedracer04 macrumors 6502a

    Speedracer04

    Joined:
    Sep 8, 2006
    Location:
    Michigan
    #8
    I had a problem where even after I set it in the preferences and I was physically looking at my hand to make sure I was right clicking properly it would still send a left click signal...This was when i first bought it so I was probably still just doing someting wrong because it has been fine since. But try resetting the mouse after you change the prefrences and see if that does anything...aka close the slider, wait for the bluetooth connection to be lost and then open the slider again.
     
  9. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #9
    i like holding the lower portion of the mouse, so i could never get used to right-clicking with my wireless mighty mouse. so i returned it and got a logitech mx revolution.
     

Share This Page