Run Mac mini without keyboard & mouse

Discussion in 'Mac mini' started by cvzyl, Jan 16, 2008.

  1. macrumors newbie

    Joined:
    Jun 2, 2007
    Location:
    Langebaan, South Africa
    #1
    I have set up my Intel Mac Mini in the living room to act as an "Apple TV" but every time I start it up it complains that there is no keyboard and mouse connected. I then have to attach a keyboard and mouse before it will continue booting.

    Is there a way to disable keyboard and mouse completely? I will either control it remotely or use the remote control for Front Row.

    Cobus
     
  2. thread starter macrumors newbie

    Joined:
    Jun 2, 2007
    Location:
    Langebaan, South Africa
    #2
    For anybody interested, found the answer to this problem on a site.

    When OS X starts up and finds no USB keyboard and mouse it goes into a search for a Bluetooth device. This is actually the bugging screen where I got stuck. Disabling this "search if normal keyboard/mouse not found" under the advanced options of Bluetooth settings (system prefs) stops this annoying behavior and you can happily boot your mac without any keyboard or mouse attached.

    Cobus
     
  3. macrumors regular

    Joined:
    Jan 10, 2008
    #3
    Thanks for posting that find. I've been looking to get a mac mini soon for exactly the same use, so you've saved me the hassle of trying to find the solution myself.
     
  4. macrumors 6502

    Joined:
    Jul 1, 2007
    #4
    I couldn't find this option. are you using leopard?
     
  5. macrumors newbie

    Joined:
    Jun 29, 2009
    #5
    Thank You!

    Thanks for posting this tip! I'm using my Mac Mini for the same reason, I think it is a much better solution than the Apple TV and it solves the Hulu problem.
     
  6. macrumors 6502a

    Joined:
    Jan 29, 2008
    #6
    same here. I have one that says 'open bluetooth setup assistant at startup when no input device is present' is that it?

    I do use a bluetooth keyboard/mouse occasionally so I wouldn't want that to stop them working.


    I found that using a 'remote' mouse via ipod touch works too (I use my mini as a HTPC usually, and it often pops this reminder up). Eg jaadu VNC, airmouse or other apps.
     

Share This Page