Safari 2.0 tabbing interface - can it be disabled?

Discussion in 'macOS' started by Snowy_River, May 3, 2005.

  1. Snowy_River macrumors 68030

    Snowy_River

    Joined:
    Jul 17, 2002
    Location:
    Corvallis, OR
    #1
    Okay, the tabbing interface with Safari is driving me nuts. I'm used to being able to hit Tab once and being in the address bar. Now, with Safari 2.0, I have to tab past the page back, page forward, and reload buttons before it highlights the address bar. Further, if I want to tab to a text field on the page, sometimes I have to tab past all of my bookmark bar items, then past other links, and so on.

    Is there some way of getting Safari to not tab to every interface element?!?
     
  2. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #2
    There's a few settings that could be the cause.

    Firstly, go to the Advanced pane of Safari's preferences and make sure "Press Tab to highlight each item on a webpage" is off. Then go to System Preferences->Keyboard & Mouse->Keyboard Shortcuts, and make sure that the "Full keyboard access" option at the bottom is set to "Text boxes and lists only".

    You can also type command-L in Safari to go directly to the address bar.
     
  3. Snowy_River thread starter macrumors 68030

    Snowy_River

    Joined:
    Jul 17, 2002
    Location:
    Corvallis, OR
    #3
    Thanks for the tip. It was the System Prefs issue. I had looked there earlier, but didn't spot that item hanging out down at the bottom. Now everything's behaving more the way I'm used to. Once again, thanks!!
     

Share This Page