safari about as slow as IE

Discussion in 'Mac Help/Tips' started by beatle888, Feb 17, 2003.

  1. beatle888 macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #1
    has anyone had performance problems with
    the latest build of safari v60? the beta before
    this, i was flying all over the net. now its a crawl.
    even the apple page that use to snap into the
    browser when i clicked on the link.

    has this been an issue with a lot of users?

    thanks for your time.
     
  2. beatle888 thread starter macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #2
    jeeeze, i just went to chimera to download their
    version of the fastest browser on the planet and
    noticed my download speed to be a blazing
    7BK per sec.


    what is UP? damn it. now i have to go back
    to chimera.....oh well safari IS a beta....still
    the version before v60 worked sooooo much
    faster.
     
  3. 8thDegreeSavage macrumors 6502

    Joined:
    Jun 5, 2002
    Location:
    Toronto, Ontario, Canada
  4. beatle888 thread starter macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #4

    damn it, i bet its my system. i guess i'll try
    fixing permissions and **** damn it to hell.

    ok, i feel a LITTLE better.
     
  5. rainman::|:| macrumors 603

    rainman::|:|

    Joined:
    Feb 2, 2002
    Location:
    iowa
    #5
    my experience is that the newest safari is a bit quicker-- page renders have improved slightly. and the cache seems better implemented. flash seems better, too.

    there's still work to be done, but for me safari is still faster than IE and damn faster than netscape/mozilla... i don't use chimera, so dunno about that.

    pnw
     
  6. howard macrumors 68020

    howard

    Joined:
    Nov 18, 2002
    #6
    it doesn't seem any faster or slower than chimera but i still noticed some bugs, even here at macrumors, the little bar that seperates the posters name from there message, those were all out of line..some a little to the left or right of others not straigt all the way down. anyway its a beta and i won't use it all the time till they FIX THOSE BUGS!!!
     
  7. lmalave macrumors 68000

    lmalave

    Joined:
    Nov 8, 2002
    Location:
    Chinatown NYC
    #7
    Hey, someone that feels like I do. I also noticed that it seemed slower, but I brushed it off as network congestion or something. Still beats IE, but definitely not Chimera...
     
  8. beatle888 thread starter macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #8
    i dont know what the problem is.
    i've heard something about safari not being
    able to even come close to download bandwidth
    compared to other browsers. i think this is true.
    every download lags.

    i downloaded chimera and i have slow page
    rendereings there tooooo. damn....does this
    mean a reformat reinstall if i want the original
    performance back? why would browsers all the
    sudden slow down? if anyone has a page where
    i can check my bandwidth will you please post
    the link?....thanks.
     
  9. beatle888 thread starter macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #9
    it looks like it might have been my connection.
    still looking into it.
     
  10. Catfish_Man macrumors 68030

    Catfish_Man

    Joined:
    Sep 13, 2001
    Location:
    Portland, OR
    #10
    www.dslreports.com (it's in the tools section)

    From what I've heard, Safari has a fairly bad network connection engine thingy, and an excellent renderer. This may be because they turned off pipelining (it can cause some problems, and Safari is supposed to be a dumbass consumer browser to replace IE). Hopefully they'll get the networking part up to par with the rest of the browser. Maybe Omniweb 5 will pair webcore/javascriptcore with a better network handler (as well as tabs and the famous Omnigroup user interface skills).
     
  11. MrMacMan macrumors 604

    MrMacMan

    Joined:
    Jul 4, 2001
    Location:
    1 Block away from NYC.
    #11
    Yeah safari is faster than IE...

    On a personal note:
    Is there a reason
    Beatles88's posts
    All line up with like
    this and never
    reach the end of
    the page? Is there
    something wrong
    with your system?

    :rolleyes:

    Might be personal style but when quoting you I like to take up less space than that...
     
  12. jaykk macrumors 6502a

    Joined:
    Jan 5, 2002
    Location:
    CA
    #12
    try emptying ur cache

    i read it somewhere that Safari have some problem with their Cache management. If you empty it once in a while, it may work faster.
     
  13. altair macrumors regular

    Joined:
    Nov 22, 2002
    Location:
    Seattle, WA
    #13
    fast

    Ive actually noticed increased speed downloading with Safari, vs IE. So i don't know what your problem is. I switched over completely to Safari. Its Grrrrreat!!!

    ~altair
     
  14. beatle888 thread starter macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #14
    Re: fast



    yes i agree, it is great. but after upgrading
    to the newest version, im crawling all over
    the freaken web. if this computer wasnt
    so damn expensive it would be out the window
    at this point.
     
  15. beatle888 thread starter macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #15


    thank you, i appreciate the link.
     
  16. beatle888 thread starter macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #16
    safari rocks


    performance decrease stemmed from my
    internet provider. i checked my dsl speed
    before sounding off....at any rate...im back
    to flying all over the web instead of crawling.

    thanks for everyones help.
     
  17. springscansing macrumors 6502a

    springscansing

    Joined:
    Oct 13, 2002
    Location:
    New York
    #17
    I hope Safari DOESN'T have pipelining. Sure its faster, but it so.... mean.
     
  18. springscansing macrumors 6502a

    springscansing

    Joined:
    Oct 13, 2002
    Location:
    New York
    #18
    Safari wouldn't knock down your DL speed. Either:

    A) Some other part of your system/modem/hardware stuff is having trouble.

    B) Your ISP is having trouble.
     

Share This Page