Safari Address Bar Autofill

Discussion in 'Mac Apps and Mac App Store' started by beedster, Oct 1, 2006.

  1. beedster macrumors newbie

    Joined:
    Sep 8, 2006
    #1
    Everytime I go to the address bar and start typing it will give me a list of sites from history/bookmarks to choose from. For example if I type www.e it will come up with every page I've visited beginning with E. Obviously I can clear my history, but how do I stop it displaying sites from my bookmarks? I use my Mac around a lot of people and don't want everyone seeing every other site I've visited. Thanks!
     
  2. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #2
    Enable Private Browsing so that there's no record of your visits to the porn sites.
     
  3. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #3
    Either use Private browsing, or clear history after you are done browsing the net. If you are really secure minded, you can also "reset safari" however all saved passwords and whatnot are also deleted.
     
  4. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #4
    Note also that items in /Users/[your account]/Library/Caches/Metadata/Safari ending in a ".webbookmark" extension will show up as you type (for example, type "1800" and almost undoubtedly 1800flowers.com will show up).
     
  5. beedster thread starter macrumors newbie

    Joined:
    Sep 8, 2006
    #5
    Thanks for the replies, but I was asking how to stop BOOKMARKED pages from popping up. Turning on private browsing/clearing history doesn't solve this problem.
     
  6. x86isslow macrumors 6502a

    Joined:
    Aug 10, 2003
    Location:
    USA
    #6
    That is one of the things I hated about Safari. Try Camino. It doesn't autofill the location bar.
     
  7. frankblundt macrumors 65816

    frankblundt

    Joined:
    Sep 19, 2005
    Location:
    South of the border
    #7
    or use a different browser just for those sites
     
  8. srf4real macrumors 68030

    srf4real

    Joined:
    Jul 25, 2006
    Location:
    paradise beach FL
    #8
    What version of Safari are you running? I do not have this problem,:confused:

    My build of 2.0.4 does not auto fill in navigtion or search bar...
     
  9. x86isslow macrumors 6502a

    Joined:
    Aug 10, 2003
    Location:
    USA
    #9
    Camino left

    Safari right
     

    Attached Files:

  10. beedster thread starter macrumors newbie

    Joined:
    Sep 8, 2006
    #10
    Thanks, I downloaded Camino. Guess I'll just need to use that while i'm out and about. Seems strange to me that Apple didn't incorporate an option to turn this feature off.

    srf4real, I'm on 2.0.4 as well.
     
  11. russelljtdyer macrumors newbie

    Joined:
    Sep 29, 2005
    #11
    Setting No History to Camino

    One more setting is needed with Camino to achieve 'Private Browsing' like effect. Go to Preferences, History, and set the "Page History: Remember visited pages for __ days" to a value of 0. With it set to 0 days, it will auto-fill addresses from the current session, but it won't keep the history once you've exited the browser. This way you won't have to remember to manually clear the history.
     
  12. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #12

    This is my biggest beef with Safari. At least give us the damn option!
     
  13. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #13
    Neither clearing history nor resetting Safari will clear the address bar history.
     
  14. tonyreedo macrumors newbie

    Joined:
    Jun 4, 2009
    #14
    space bar to stop autofill in address bar

    I saw a great suggestion/workaround to the autofill feature in the Safari address bar. Type two spaces (hit the spacebar twice) before the address and it won't fill in. Handy!

    Otherwise, let me voice how Safari SUCKS for not dealing with this annoying feature...and it's not only porn that is annoying popping up, there are competing clients and products, research, reference searches, simply stumbling onto crazy sites, it's endless.

    Safari, please DO SOMETHING!

    thnx
     
  15. koesherbacon macrumors member

    Joined:
    Jun 5, 2009
    #15
    Okay, how about this question.

    Once I typed "fa" expecting it to autocomplete into "facebook.com". But in that one instance, I must've hit enter too quickly, and now whenever I type "fa" it wants me to go to "fa/" instead of "facebook.com". Another is "the" which instead of taking me to the sites that begin with "the", it only wants me to go to "the/". And misspelled ones continue this way, too :(

    Is there anyway that I can clear out these mistyped urls?
     

Share This Page