Safari auto-complete in address bar

Discussion in 'macOS' started by WillJS, Feb 25, 2007.

  1. WillJS macrumors 65816

    WillJS

    Joined:
    Jan 6, 2007
    #1
    For example, when I type "www.youtube.com" it adds "/watch?v=ALQwmQrM-Z8" highlighted in blue. Therefore when I hit enter, it goes to "www.youtube.com/watch?v=ALQwmQrM-Z8", not "www.youtube.com"

    It seems like there's some sort of auto complete going on, which i can't figure out how to turn off! :eek:

    Any help is welcome! (I want to turn it off)
     
  2. Frisco macrumors 68020

    Joined:
    Sep 24, 2002
    Location:
    Utopia
    #2
    If you find the url prediction getting in the way of your inputting your own addresses, for instance, if you type www.domain.com but it insists on filling in 'www.domain.com/arbitrary/example.htm', you can hit space at the end of your desired url to prevent it from getting in the way.

    Here's one workaround:
    (1) In Safari go to History>Clear History
    (2) Close Safari
    (3) Go to Home>Library>Safari
    (4) Get Info on the File History.plist
    a) Change Ownerships & Permissions to Read Only
    b) Check the locked tab on top
    c) Click on the little lock icon on the bottom

    Safari stills remembers the history until you close Safari


    Alternatively I believe you can use TinkerTool
    One of the options is to set the number of sites to store in your history...setting to 0 should eliminate your problem
     
  3. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #3
    I also find that hitting enter very quickly after you type the last letter of the URL prevents the auto-complete from moving to another entry, so you get sent to just the URL you typed in.
     

Share This Page