Safari Back Button not working

Discussion in 'Mac Apps and Mac App Store' started by spellflower, Mar 30, 2006.

  1. spellflower macrumors regular

    Jun 7, 2005
    Ocassionally, I'll click on a link, the page will load in place of the old page (not in a new window), and the "back button" will go gray. Delete doesn't work, and the only way to get back is through the history. Anyone else having this problem?
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    I've never had this problem. Does it only happen on secured sites? Do you have any hacks installed to either modify Safari or change the GUI? :)
  3. grapes911 Moderator emeritus


    Jul 28, 2003
    Citizens Bank Park
    Does it only happen on certain sites? Or is it toatally random?

    What OS are you using? What version of Safari do you have?
  4. janey macrumors 603


    Dec 20, 2002
    sunny los angeles
    which site? sometimes people making websites screw up the back button behaviour on sites using ajax (think gmail), that might be your problem.
  5. calebjohnston macrumors 68000


    Jan 24, 2006
    ... they never want you to leave.

    ::Looks up of Mac Rumors and realizes both the red circle and back button are greyed out::
  6. 1dterbeest macrumors regular

    Feb 14, 2006
    Waupun, WI
    Safari, what a crazy love affair we have.
    I love how pretty it is and I love the speed
    in loading. I love so many things about you.

    What I don't love is all the crazy erratic
    arbitrary behaviors you exhibit. The wierd
    problems that you exhibit for no reason
    only for short periods are wierd.

    Safari, you are a moody girlfriend.
  7. spellflower thread starter macrumors regular

    Jun 7, 2005
    It seems to happen completely randomly, but if there is anything that mightbe related it could be gmail. Of course, gmail is the site I use most frequently, so it's impossible to tell. I think it was in gmail that I first encountered the problem, though, since then it's happened on some other random sites too. I use the latest version of OSX, and Safari, and I wouldn't know where to begin to hack anything but weeds in the yard. ;) It sounds like this is just one of those thins, and I'll have to learn to live with it or find a less attractive but lower maintenence web browser!
  8. spellflower thread starter macrumors regular

    Jun 7, 2005
    I have tried resetting Safari, but it's tough to say if that does anything. The problem goes away for a little while, but it does that sometimes anyway. It still comes back. I'm really noticing it most in connection w/ gmail, though, so I think that's the culprit. I'm having some other weird gmail issues, so I'm going to start a thread about that. Thanks for the advice, though.
  9. dogbone macrumors 68020


    Sep 16, 2005
    S33.687308617200465 E150.31341791152954
    separated at birth.

    It's the only thing that kept me hanging on. Once I discovered UNO and the new UNO grapple theme for was a no brainer.

    Attached Files:

Share This Page