Safari buggy in Mountain Lion

Discussion in 'OS X Mountain Lion (10.8)' started by Unusual, Aug 9, 2012.

  1. macrumors newbie

    Aug 9, 2012
    Is it me, or has anyone else noticed how buggy Safari is in Mountain Lion.

    1. It never quits, the quit button is greyed out. (have to force quit)
    2. The little (x) sometimes never appears on the tabs when browsing multiple sites.
    3. Web page elements are sometimes not shown (i.e. background images) until the the cache is removed.

    Such irritating bugs, are these problems known by apple - or is it a case of sods law only with my computer? :(

    I'm on a 2011 Macbook Air if that makes any difference... :confused::confused:
  2. macrumors 65832


    Aug 17, 2011
    Thus far mine work each time. Have you tried the Command key + Arrow key to go back ?

    Attached Files:

  3. macrumors 6502a


    Aug 26, 2004
    I reckon you are right when you say that its buggy, I tried downloading a demo from Adobe's website and it just froze, I managed to quit the thing and upon retrying it froze again this time slowing OSX right down to a crawl.

    I had to reboot the mac to get it working normally.

    Come on Apple test the software before releasing it!
  4. thread starter macrumors newbie

    Aug 9, 2012
    Ah yeah, going back and forth isn't a problem. Though the ( X ) on the tab goes missing. Only resolution is to right click on the tab to close it.

    Something is def up with it, the old version on osx lion worked flawlessly. Now I'm thinking of going with firefox while apple "slowly" releases a new version. :(
  5. macrumors member

    Jul 27, 2012
    If I were you I would:
    1. Disable all your Safari extensions and check whether the issue remains. If that doesn't work,
    2. Clean Adobe Flash's cache from Settings. Uninstall flash and see if the problem persists.
    3. Preferences->Security->Uncheck all of "Web content," try enabling them each again one by one and see which one's the culprit.
    4. And finally, from Safari's menu bar, go Safari->Reset Safari..., if all the above doesn't work for you
  6. macrumors 68030


    Jun 24, 2010
    2011 AIR here. I don't have any of your symptoms. In fact, it's quite.. umm.. snappier. :p
  7. thread starter macrumors newbie

    Aug 9, 2012
    Thanks for the help here, tried all the steps none seem to work. :(

    :( Must be my mac then, wonder if anyone else has the problem.

    The closest thing I could find to resolve the problem is the following link ->

    Although it didn't resolve my situation, I do have 1password installed but even after removing the extension no joy. :(
  8. macrumors 68030


    Jun 24, 2010
    That could be the case because I don't use 1Password (yet).
  9. macrumors 68000


    May 31, 2012
    New England
    I'm using 1Password with Safari with no issues.

    Theoretically you can delete and re-install Safari, but this can lead to other problems with your system. If it was me, I would either try re-installing ML or switch to another browser and wait to see if a future update corrects the problem. I did a side-by-side comparison of Safari and Firefox last night and found that Firefox was actually a little quicker to load pages, but did use a bit more memory. It wouldn't be a bad choice.
  10. LxHunter, Aug 10, 2012
    Last edited: Aug 10, 2012

    macrumors 6502

    Nov 14, 2010
    Have been using 10.8 since released.
    This morning I woke my iMac from sleep - Safari was super slow - unusable
    I have tried every fix I could find searching the net - a few hours wasted.
    Gave up and using Chrome.

    Hope we have a fix in 10.8.1

    Update: I think the Google Soccer Doodle may be part of the problem. I used AdBlock to kill it - now I can switch tabs faster.
  11. macrumors newbie

    Aug 13, 2012
    Sydney NSW, Australia
    Mountain Lion (10.8) and Safari bugs

    Hello forum members,
    I want to chime in and list the bugs in Safari since my install of Mac OS 10.8.0

    Java does not function as it should. It's buggy and generates errors, stops on errors and wont load data from some websites correctly.

    My main concern centres around my work place and our use of IP video cameras to record people coming and going. We login to individual camera's on occasion to check streaming. 10.6.x and Safari never failed at this but 10.8 and the new Safari will load the first few frames of a stream and then the stream will halt. Investigation has pointed towards Java and a possible Safari incompatibilty. Google Chrome and Opera have similar issues, FireFox on the other hand works as it should.

    We also use FileMaker Pro 12 to display some of our camera feeds (custom WebViewer windows) for a receptionist, which work great under 10.6.8 and it's underlying WEB Kit engine. Mac OS 10.8 fails on this front, loading a few frames of live content, with the stream freezing there after. This does not affect the functionality of FileMaker just the the live streaming from our camera's.

    Any input from other readers would be of assistance.

    p.s. A quick trip to a Genius Bar was futile as the rep had no knowledge of Mountain Lion, Java or Safari... haha
  12. macrumors 65816


    Jun 24, 2010
    I've experienced the X on the tabs not functioning. I simply used Command + W to close the tab. My main concerns are the crashes I've experienced on Safari 6.0 under 10.8. I didn't have a single crash ever on the last revision of Safari on 10.7, so that's kind of upsetting.

    Hopefully they address these issues in the upcoming software update.

Share This Page