Safari bugs: losing the minimise button

Discussion in 'macOS' started by Thomas Harte, Dec 20, 2006.

  1. Thomas Harte macrumors 6502

    Joined:
    Nov 30, 2005
    #1
    Hi, Safari seems to be disabling its minimise button (and associated menubar entry) on my machine quite a lot recently. Is anyone else experiencing this? If so, have they figured out what the action is that causes it, if it can be isolated at all? I shouldn't have to adapt my usage behaviour, but I will if necessary because this is really annoying.

    Stats: OS X 10.4.8, all the latest security patches and suchlike installed. Machine is a Core Duo MacBook Pro with 2GB RAM. Safari reports itself as Version 2.0.4 (419.3).
     
  2. Unorthodox macrumors 65816

    Unorthodox

    Joined:
    Mar 3, 2006
    Location:
    Not at the beach...
    #2
    Do a spotlight search for "com.apple.safari.plist" move this file to your desktop and then restart/start Safari. Does minimize work now?
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    There's a bug related to Exposé that'll do this in most apps, but it shouldn't be something that happens terribly often. Do you have any Safari plug ins or add ons installed? :)
     
  4. Thomas Harte thread starter macrumors 6502

    Joined:
    Nov 30, 2005
    #4
    I have PithHelmet, but nothing beyond that. However that's irrelevant: I had incorrectly diagnosed the problem. The problem is that whenever the SDL/OpenGL app that I'm working on switches in and out of full screen, all apps lose their minimise buttons. So I'll keep the Exposé bug in mind but otherwise go and hassle SDL people.
     

Share This Page